This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 90244 - writing data to the network
writing data to the network
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-05 18:09 EDT by SuperbepS
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-06 04:34:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description SuperbepS 2003-05-05 18:09:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.2.1) Gecko/20030409
Debian/1.2.1-9woody2

Description of problem:
About a month ago on a server that handles only a forum (with invision
powerboard) we started to have a lot of error for images that doesn't exist
(misconfiguration of some skin). At the same time apache started to grow up in
memory getting all resources and than slow down the machine, until a service
restart!
the only error that i can find in the logs (debug mode!!!) are:
(104)Connection reset by peer: core_output_filter: writing data to the network
and sometimes (only few):
(32)Broken pipe: core_output_filter: writing data to the network

according to apache docs the first error could be caused by sendfile, but in
apache 2.0.40 there is no way to disable this feature. I tried to disable MMAP
but the problem still persist.
About the fact that not found errors and this problem are related i'm not very
sure but it's a fact that about two weeks ago we reduced drastically the errors
and apache stopped to start  once a day and moved to once a week.

Version-Release number of selected component (if applicable):
httpd-2.0.40-11.3

How reproducible:
Didn't try


Additional info:
Comment 1 Joe Orton 2003-05-06 04:34:30 EDT
The "Connection reset" and "Broken pipe" errors are quite normal for a
production web site - this can happen if e.g. someone hits the "Stop" button
before a page loads. 

If you have a script which is using lots of memory - this is not an httpd bug! 
If you're using PHP make sure the "memory_limit" config option is set in
/etc/php.ini  - this should help prevent memory leaks. 
Comment 2 Milan Kerslager 2003-10-08 02:34:17 EDT
There is a possibility to pass --without-sendfile to ./configure script.
This bug is closed so this is only FYI. Apache 2.0.44 and later has
EnableSendfile On|Off option (you need at least Fedora release).

Note You need to log in before you can comment on or make changes to this bug.