Bug 902450 - pcs update resource with operation does not work as expected
Summary: pcs update resource with operation does not work as expected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-21 17:31 UTC by Jaroslav Kortus
Modified: 2018-12-03 18:10 UTC (History)
8 users (show)

Fixed In Version: pcs-0.9.81-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: A user created a resource with a monitor operation and then attempts to update that resources monitor operation, Consequence: Instead of updating the monitor operation a new operation is created Fix: pcs was updated to use an existing monitor operation when updating the resource Result: It is now possible to update resource monitor operations (instead of just creating new monitor operations)
Clone Of:
Environment:
Last Closed: 2013-11-21 11:50:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1633 normal SHIPPED_LIVE pcs bug fix and enhancement update 2013-11-20 21:53:48 UTC

Description Jaroslav Kortus 2013-01-21 17:31:10 UTC
Description of problem:
pcs update resource with operation does not work as expected. Instead of updating the operation, the parameters are added to the resource.

Version-Release number of selected component (if applicable):
pcs-0.9.26-9.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. pcs resource create dummystateful ocf:pacemaker:Stateful op monitor interval="30s"
2. pcs resource update dummystateful op monitor interval="19s"
3.
  
Actual results:
$ pcs resource show dummystateful
Resource: dummystateful
  interval: 19s
  op monitor interval=30s


Expected results:
$ pcs resource show dummystateful
Resource: dummystateful
  op monitor interval=19s


Additional info:

Comment 2 Chris Feist 2013-02-20 23:32:48 UTC
Fixed upstream: https://github.com/feist/pcs/commit/6a95a470e6811be0e7ff7ca5eb9be88aeb9f3c74
https://github.com/feist/pcs/commit/0a50beea8a327c1eb8b02a0af6fc9821b4b330e6

This replaces the first monitor/start/stop/etc. operation that is found for the specified resource (or if no such operation is found it creates a new one).

Comment 8 Robert Scheck 2013-07-10 20:38:01 UTC
Are there any plans to get this fixed in RHEL 6.4?

Comment 9 Jaroslav Kortus 2013-07-11 12:38:39 UTC
That's very unlikely as pacemaker is still techpreview in 6.4 (AFAIK).

Comment 10 Robert Scheck 2013-07-11 12:41:39 UTC
Cross-filed case 00902474 on the Red Hat customer portal.

Comment 11 Robert Scheck 2013-07-11 23:33:30 UTC
Feedback: We applied the patches from comment #2 to pcs-0.9.26-10.el6_4.1 and
it now works as expected.

Comment 13 Chris Feist 2013-08-13 21:25:11 UTC
[root@ask-02 ~]# pcs -f test.xml resource create dummystateful ocf:pacemaker:Stateful op monitor interval="30s"
[root@ask-02 ~]# pcs -f test.xml rseource update dummystateful op monitor interval=19s
[root@ask-02 ~]# pcs -f test.xml resource --full
 Resource: dummystateful (class=ocf provider=pacemaker type=Stateful)
  Operations: monitor interval=19s (dummystateful-monitor-interval-19s)
[root@ask-02 ~]# pcs -f test.xml resource update dummystateful op monitor interval=29s
[root@ask-02 ~]# pcs -f test.xml resource --full
 Resource: dummystateful (class=ocf provider=pacemaker type=Stateful)
  Operations: monitor interval=29s (dummystateful-monitor-interval-29s)
[root@ask-02 ~]#

Comment 15 Maël Lavault 2013-09-06 14:52:08 UTC
It still doesn't works with pcs-0.9.26-10.el6_4.1 :s

Comment 23 errata-xmlrpc 2013-11-21 11:50:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1633.html


Note You need to log in before you can comment on or make changes to this bug.