Bug 902453 - pcs allows you to specify non-existent resource agent
Summary: pcs allows you to specify non-existent resource agent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-21 17:41 UTC by Jaroslav Kortus
Modified: 2013-11-21 11:50 UTC (History)
4 users (show)

Fixed In Version: pcs-0.9.64-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: A user accidentally specified a non-existent resource agent when creating a resource Consequence: The resource would never start and it could be confusing to the user why this didn't happen Fix: pcs provides an error when a user attempt to create a resource with a non existent resource agent type (with the ability to override if necessary) Result: Users will be notified that they may have selected a bad resource agent when creating a resource
Clone Of:
Environment:
Last Closed: 2013-11-21 11:50:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1633 normal SHIPPED_LIVE pcs bug fix and enhancement update 2013-11-20 21:53:48 UTC

Description Jaroslav Kortus 2013-01-21 17:41:09 UTC
Description of problem:
pcs allows you to specify non-existent resource agent.


Version-Release number of selected component (if applicable):
pcs-0.9.26-9.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. pcs resource create dummystateful nonsense op monitor interval="5s"
2.
3.
  
Actual results:
Full list of resources:

 dummystateful	(ocf::heartbeat:nonsense):	Stopped 


Expected results:
pcs should catch this error while parsing the arguments. As it can already provide the list of resources and providers, it could filter the input against them to see if obvious mistake has not been made.

If error is detected, it should be printed (like "Specified resource is not valid, use pcs resource agents for a full list") and exit code should be non-zero.

Additional info:

Comment 5 Laura Novich 2013-06-20 09:30:35 UTC
Marking with docs_scoped - as this issue will not be documented in the Virtualization Administration Guide for RHEL 6.5

Comment 9 Chris Feist 2013-08-13 21:27:49 UTC
[root@ask-02 ~]# pcs -f temp.xml resource create dummystateful nonsense op monitor interval="5s"
Error: Unable to create resource 'nonsense', it is not installed on this system (use --force to override)
[root@ask-02 ~]# echo $?
1

Comment 12 errata-xmlrpc 2013-11-21 11:50:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1633.html


Note You need to log in before you can comment on or make changes to this bug.