Bug 90246 - Install does not setup XF86Config correctly to work with the ATI Radeon 7500 graphics card
Install does not setup XF86Config correctly to work with the ATI Radeon 7500 ...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-05 18:33 EDT by Bob Alberts
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 12:39:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file generated by install (3.05 KB, text/plain)
2003-05-07 19:16 EDT, Bob Alberts
no flags Details
Log file for XFree86 (38.07 KB, text/plain)
2003-05-07 19:19 EDT, Bob Alberts
no flags Details

  None (edit)
Description Bob Alberts 2003-05-05 18:33:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
After a fresh install of Redhat Linux 9.0, the XF86Config file in
/etc/X11/ is not set correctly for the ATI Radeon 7500 graphics card.
Running startx causes the display to blank out and the machine does
not respond to any keystrokes except Ctrl-Alt-Del.  After some
experimentation, I found that adding the line
VideoRam 2048
to the drivers section and reducing the color depth from 24 to 16
allows X-windows to work.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install Redhat 9.0 on a machine with an ATI 7500 graphics card
2. Reboot the machine
3. run startx


Actual Results:  X-windows will not start and the display goes blank.

Expected Results:  Normally, X-windows should start.

Additional info:

ATI Radeon 7500 graphics card
Pentium 3.06 GHz CPU
Dell 7200 FP Monitor

adding VideoRam 2048 to the XF86Config file and reducing the color depth from 
24 to 16 allows X-windows to start properly.
Comment 1 Mike A. Harris 2003-05-05 19:34:37 EDT
Red Hat Linux 9 has been extensively tested on Radeon 7500, in fact probably
more than any other video card.  It works perfectly fine for me, and all other
people as well, or I'd get seriously flooded with a very large number of bug
reports.

So if it is not working for you, then something is obviously very different
about your specific video card, or your system in some way.  You'll have
to provide greater details about the problem, and attach your X server log
file and config file that is not working, using bugzilla's file attachment
feature.
Comment 2 Bob Alberts 2003-05-07 19:16:21 EDT
Created attachment 91546 [details]
XF86Config file generated by install

After performing a fresh install of Linux 9, this is the XF86Config
file genterated.  I am not able to run Xwindows, the display blanks
out a few seonds after running the startx command.
Comment 3 Bob Alberts 2003-05-07 19:19:10 EDT
Created attachment 91547 [details]
Log file for XFree86

This is the log file generated by XFree86 when the system would
not boot into Xwindows.
Comment 4 Bob Alberts 2003-05-07 19:23:16 EDT
I have attached the XF86Config file generated by the install program and
the XFree86 log file generated when trying to get start Xwindows
Comment 5 Mike A. Harris 2003-05-07 22:12:41 EDT
Your X log file shows that you are using kernel 2.4.20-6smp, which is
definitely not what shipped in Red Hat Linux 9.

Are you using Red Hat Linux 8.0.x phoebe beta with pieces of Red Hat Linux 9
installed on top of it?  If so, that is a potential cause of problems.

A more likely problem though, is that your video memory is bad.  As I mentioned
above, Radeon hardware works very solidly in Red Hat Linux 9, and any major
flaws are either fixed in rawhide XFree86, or are fairly well known.
Definitely no problems of this sort have been reported, so I'm inclined to
believe that your video memory is faulty, and by using a different depth,
and the VideoRAM option, you are blocking out the bad area of memory, and
the accelerator then can't use it and corrupt.

Try removing the VideoRAM option, setting the resolution to 640x480 16bit,
and disabling acceleration with "noaccel".  Does that work?

Let me know and we'll see where we can go next.

Comment 6 Thomas Schachtner 2003-10-02 04:52:58 EDT
Sorry to break into this thread, but
I am facing the same problems using a ATI Radeon 7500 card.
During the graphical install process the card was working fine, but
after typing startx the display went black.
The machine is not hanging completely, it is still possible to connect via SSH.
I verified this with more than one card, so it seems not to be a memory 
problem... This would be really a coincidence!

The card has three connectors:
- standard VGA
- DVI
- and Composite

I connected to the standard VGA port. Mabe the card activated the DVI only...
If so, how can this be changed?
Comment 7 Thomas Schachtner 2003-10-02 06:26:44 EDT
After some more trying and looking around in the Net we probably found the 
root cause for the problem...

The X Server seems to have a problem with the ATI Radeon 7500 and DRI enabled.

Pls. have a look at following site: http://bugs.xfree86.org/show_bug.cgi?id=672

I tried to comment the section DRI in the XF86Config file and it worked!
Comment 8 Mike A. Harris 2003-10-02 07:00:42 EDT
PCI Radeon support for DRI is experimental only, and requires the user to
manually enable ForcePCIMode in the config file as per the Radeon manpage.
PCI Radeon hardware support is mostly provided as-is due to the rarity of this
hardware, and the incomplete support for it in XFree86.  I have only PCI Radeon
7000 available currently.  Problems that arise with PCI Radeon tend to be
machine specific or random oddities.   It works for some people and not at all
for others.

To the original reporter:  Please indicate if this is a PCI card, or an AGP
card.  Also, please indicate if the problem goes away if you use a CRT instead
of DFP display.
Comment 9 Mike A. Harris 2003-10-02 07:07:28 EDT
Also please attach the config file and log file from the working setup too,
for comparitive purposes.
Comment 10 Mike A. Harris 2004-01-10 12:39:28 EST
If this problem still occurs in Red Hat Enterprise Linux 3 or Fedora
Core 1 with all Red Hat supplied updates applied, and no 3rd party
kernel modules installed, then feel free to update the report with
the information requested in comment #9 above, and reopen the report.

Closing as WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.