Bug 902523 - sata_mv driver not working
Summary: sata_mv driver not working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-21 21:01 UTC by Wolfgang Denk
Modified: 2013-02-16 01:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-26 16:01:27 UTC


Attachments (Terms of Use)
3.6.11-1.fc17.x86_64 and 3.7.2-204.fc18.x86_64 boot logs (4.01 KB, application/x-gzip)
2013-01-21 21:01 UTC, Wolfgang Denk
no flags Details

Description Wolfgang Denk 2013-01-21 21:01:41 UTC
Created attachment 684653 [details]
3.6.11-1.fc17.x86_64  and  3.7.2-204.fc18.x86_64  boot logs

Description of problem:

Disks attached to a Marvell Technology Group Ltd. MV88SX6081 8-port
SATA II PCI-X Controller (Supermicro AOC-SAT2-MV8) are not recognized
with the Fedora 18 provided kernel.


Version-Release number of selected component (if applicable):

kernel-3.7.2-204.fc18.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Boot the system, or unload/load the sata_mv driver module
2.
3.
  
Actual results:

Driver reports some errors and disables all attached drives.

Expected results:

Driver allows access to all attached drives.

Additional info:

The same hardware configuration works perfectly fine with Fedora 17
(i. e. with the 3.6.11-1.fc17.x86_64 kernel).

Other hardware information:

- Supermicro X8SAX mainboard
- Intel Core i7 quad CPU
- 24 GB RAM
- Supermicro AOC-SAT2-MV8 S-ATA controller (Marvell MV88SX6081)
- 8 x Seagate ST3250620NS disk drives attached to MV88SX6081

See also attached boot logs for the FC17 versus FC18 kernels.

Comment 1 Josh Boyer 2013-01-22 13:42:56 UTC
I'll have a patch shortly.  This looks like https://bugzilla.kernel.org/show_bug.cgi?id=51881

Comment 2 Josh Boyer 2013-01-22 13:51:23 UTC
Please give this scratch build a test when it completes:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4893420

and let us know if it solves this particular issue for you.

The fix will be needed in F17 as well.

Comment 3 Wolfgang Denk 2013-01-22 18:33:14 UTC
(In reply to comment #2)
> Please give this scratch build a test when it completes:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4893420
> 
> and let us know if it solves this particular issue for you.
> 
> The fix will be needed in F17 as well.

The 3.7.4-201.1.fc18.x86_64 kernel boots fine on my system - it does fix the problem for me.

Thanks a lot!

Comment 4 Josh Boyer 2013-01-22 18:38:37 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Please give this scratch build a test when it completes:
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=4893420
> > 
> > and let us know if it solves this particular issue for you.
> > 
> > The fix will be needed in F17 as well.
> 
> The 3.7.4-201.1.fc18.x86_64 kernel boots fine on my system - it does fix the
> problem for me.
> 
> Thanks a lot!

Great.  Thanks for testing.  I'll get this into Fedora today.

Comment 5 Fedora Update System 2013-01-23 20:07:42 UTC
kernel-3.7.4-204.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.7.4-204.fc18

Comment 6 Fedora Update System 2013-01-24 20:49:45 UTC
kernel-3.7.4-104.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.7.4-104.fc17

Comment 7 Fedora Update System 2013-01-24 22:39:44 UTC
Package kernel-3.7.4-204.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.7.4-204.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1443/kernel-3.7.4-204.fc18
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-01-26 16:01:29 UTC
kernel-3.7.4-204.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-01-29 16:09:15 UTC
kernel-3.7.5-101.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.7.5-101.fc17

Comment 10 Fedora Update System 2013-02-04 21:57:30 UTC
kernel-3.7.6-102.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.7.6-102.fc17

Comment 11 Fedora Update System 2013-02-16 01:21:16 UTC
kernel-3.7.6-102.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.