This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 902624 - [zh_CN] Invalid hotkey (&V) in 'Character Codings' dialog of gedit.
[zh_CN] Invalid hotkey (&V) in 'Character Codings' dialog of gedit.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gedit (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
QE Internationalization Bugs
: i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 01:01 EST by Lijun Li
Modified: 2016-02-03 05:56 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the 'Character Encodings' dialog window contained an invalid keyboard shortcut when using Simplified Chinese localization. This has been fixed and the dialog now uses the correct keyboard shortcut.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 05:56:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Invalid hotkey (&V) in 'Character Codings' dialog of gedit (66.22 KB, image/png)
2013-01-22 01:06 EST, Lijun Li
no flags Details
patch (477 bytes, patch)
2016-01-12 14:38 EST, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Lijun Li 2013-01-22 01:01:37 EST
Description of problem:
[zh_CN] Invalid hotkey (&V) in 'Character Codings' dialog of gedit.

Version-Release number of selected component (if applicable):
[root@localhost ~]# rpm -q gedit
gedit-2.28.4-3.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install latest rhel6.4 client build.
2. Open gedit.
3. File->Open.
4. Select 'Add or Remove...' from 'Character Coding' list in the 'Open Files' dialog.

  
Actual results:
[zh_CN] Invalid hotkey (&V) in 'Character Codings' dialog of gedit.

Expected results:
[zh_CN] The hotkey for 'Available' should be linke this '_V' but not '&V' in 'Character Codings' dialog of gedit.

Additional info:
Comment 1 Lijun Li 2013-01-22 01:06:49 EST
Created attachment 684890 [details]
Invalid hotkey (&V) in 'Character Codings' dialog of gedit
Comment 3 RHEL Product and Program Management 2013-10-13 20:03:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Noriko Mizumoto 2015-11-22 23:43:04 EST
Carlos and Robert
I can't see the string in question at 'nautilus' master (https://l10n.gnome.org/module/nautilus/). 
Could you please advise how can we update?
Comment 5 sandeep shedmake 2015-12-22 05:46:55 EST
From Comment 4,

The string [1] in question could be observed in RHEL dist git repository (especially, rhel-6.8 branch of 'gedit' component)

$ grep -wn "&V" rhel-6.8/gedit-2.28.4/po/zh_CN.po
606:msgstr "可用编码(&V):"
$ echo $?
0


Perhaps, upstream (https://git.gnome.org/browse/gedit/tree/po/zh_CN.po?h=gnome-2-28) too needs a fix/commit.


[1]
Concerned lines from ~/rhel-6.8/gedit-2.28.4/po/zh_CN.po

 604 #: ../gedit/dialogs/gedit-encodings-dialog.ui.h:1
 605 msgid "A_vailable encodings:"
 606 msgstr "可用编码(&V):"
Comment 6 sandeep shedmake 2015-12-23 01:29:58 EST
As per Comment 0, changing component to 'gedit'.
Comment 7 Matthias Clasen 2016-01-12 14:38 EST
Created attachment 1114109 [details]
patch

Here is a patch that fixes this mistranslation
Comment 14 errata-xmlrpc 2016-02-03 05:56:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0114.html

Note You need to log in before you can comment on or make changes to this bug.