Bug 90264 - krb4 support not linked
krb4 support not linked
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: fetchmail (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-05 23:22 EDT by Jack Neely
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-06 19:10:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Neely 2003-05-05 23:22:48 EDT
Description of problem:
fetchmail doesn't seem to like krb4.  All the libraries seem to be linked
in...compile seems fine but fetchmail complains that krb4 support is not linked
in when trying to use KPOP.

[slack@narsil fetchmail-6.2.0]$ ./fetchmail -d0 -v 
fetchmail: Kerberos V4 support not linked.
fetchmail: 6.2.0 querying uni00mh.unity.ncsu.edu (protocol POP3) at Mon 05 May
2003 11:18:43 PM EDT: poll started
fetchmail: 6.2.0 querying uni00mh.unity.ncsu.edu (protocol POP3) at Mon 05 May
2003 11:18:43 PM EDT: poll completed
fetchmail: Query status=7 (ERROR)
fetchmail: normal termination, status 7

My fetchmailrc looks like:
poll uni00mh.unity.ncsu.edu
        proto KPOP
        port 1109
        auth kerberos_v4
        user "jjneely" is "slack"
        smtp localhost


Version-Release number of selected component (if applicable):
fetchmail-6.2.0-3

I have reverted to fetchmail-5.9.0-21.8.0 which works fine.
Comment 1 John 2003-07-06 19:40:55 EDT
I'm seeing the same thing, using a fetchmailrc which worked perfectly in Red Hat
8.0 and earlier.
Comment 2 Jack Neely 2003-08-31 13:58:21 EDT
fetchmail-6.2.0-krb5-config.patch doesn't seem to include the right magic to get
the krb4 stuff linked in.  Building without it and specifying where the kerberos
install is gets a fetchmail build with krb4 support.
Comment 3 Miloslav Trmač 2005-06-06 19:10:38 EDT
I'm sorry for the late response.

Apparently krb4 support is correctly linked in in current releases,
e.g. fetchmail-6.2.5-7.

Note You need to log in before you can comment on or make changes to this bug.