Bug 90266 - DirectoryIndex directive does not work
Summary: DirectoryIndex directive does not work
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-06 05:20 UTC by Joe Acosta
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-07 03:58:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Acosta 2003-05-06 05:20:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
The Directove DirectoryIndex, does not error out nor does it seem to work.

Version-Release number of selected component (if applicable):
httpd-2.0.40-21.1

How reproducible:
Always

Steps to Reproduce:
1. Add the directove DirectorIndex and add default.php as the default directory
index
2. make sure php works by setting up a test page
3. visit your web server where you should see your default.php page.
    

Actual Results:  index.html is served

Expected Results:  default.php should be served

Additional info:

I know php is working cause I can go type default.php as the URL and it loads
the php page just fine.

This worked in apache 1.3.

Comment 1 Joe Acosta 2003-05-07 03:58:51 UTC
Not a bug.  I made a booboo doh!  

It seems the redhat-config-httpd program configured a virtualserver only I did
not put the DirectoyIndex command in that virtual server. 



Note You need to log in before you can comment on or make changes to this bug.