Bug 90268 - rpm install upgrade Segmentation fault after upgrade gcc to gcc-2.96-113
rpm install upgrade Segmentation fault after upgrade gcc to gcc-2.96-113
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
http://web.holmglad.edu.hk/~hgc-dww/s...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 01:44 EDT by mortin
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-02 10:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mortin 2003-05-06 01:44:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Problem with rpm install upgrade after upgrade gcc to gcc-2.96-113. There is no 
error with rpm -qa and rpm --rebuilddb and check with db_verify /var/lib/rpm is 
OK.

I am consider resintall however this machine is in production now.

Any help will be appreciated


Moris

Version-Release number of selected component (if applicable):
rpm -4.0.4 kernel-2.4.18 db3-3.3.11-6

How reproducible:
Always

Steps to Reproduce:
1.rpm -ivh -vv lynx-2.8.4-18.i386.rpm
2.
3.
    

Actual Results:  Error as follow
---------------
rpm -e -vv gcc-java

D: opening  db environment /var/lib/rpm/Packages create:mpool
D: opening  db index       /var/lib/rpm/Packages  mode=0x82
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name  mode=0x82
D: ========== --- gcc-java-2.96-113
D: opening  db index       /var/lib/rpm/Requirename  mode=0x82
D: opening  db index       /var/lib/rpm/Basenames  mode=0x82
D:     erase: gcc-java-2.96-113 has 11 files, test = 0



---------------------------------------
rpm -ivh -vv lynx-2.8.4-18.i386.rpm


D: ============== lynx-2.8.4-18.i386.rpm
D: Expected size:      1539499 = lead(96)+sigs(433)+pad(7)+data(1538963)
D:   Actual size:      1539499
D: opening  db environment /var/lib/rpm/Packages create:mpool
%0
Comment 1 Jeff Johnson 2003-05-06 12:40:36 EDT
Doing --rebuilddb with rpm-4.1 or later will fix your problem.

Reopen, and give me a URL to a tarball of your database if you cannot do
the --rebuilddb yourself, or if the above does not fix.
Comment 2 mortin 2003-05-08 08:23:44 EDT
Sorry I am unable to upgrade to rpm-4.1 since my linux version is 7.3
#rpm -Uvh rpm-4.1-1.06.i386.rpm 
error: failed dependencies:
        popt = 1.7 is needed by rpm-4.1-1.06
        libelf >= 0.8.2 is needed by rpm-4.1-1.06
        libelf.so.0   is needed by rpm-4.1-1.06
        rpm = 4.0.4 is needed by rpm-devel-4.0.4-7x.18
        rpm = 4.0.4 is needed by rpm-build-4.0.4-7x.18
        rpm = 4.0.4 is needed by rpm-python-4.0.4-7x.18
        librpm-4.0.4.so   is needed by gnorpm-0.96-14
        librpm-4.0.4.so   is needed by kdeadmin-3.0.0-4
        librpm-4.0.4.so   is needed by ucd-snmp-4.2.4-3
        librpm-4.0.4.so   is needed by rpm-build-4.0.4-7x.18
        librpm-4.0.4.so   is needed by ucd-snmp-utils-4.2.4-3
        librpm-4.0.4.so   is needed by rpm-python-4.0.4-7x.18
        librpmbuild-4.0.4.so   is needed by kdeadmin-3.0.0-4
        librpmbuild-4.0.4.so   is needed by rpm-build-4.0.4-7x.18
        librpmdb-4.0.4.so   is needed by gnorpm-0.96-14
        librpmdb-4.0.4.so   is needed by kdeadmin-3.0.0-4
        librpmdb-4.0.4.so   is needed by ucd-snmp-4.2.4-3
        librpmdb-4.0.4.so   is needed by rpm-build-4.0.4-7x.18
        librpmdb-4.0.4.so   is needed by ucd-snmp-utils-4.2.4-3
        librpmdb-4.0.4.so   is needed by rpm-python-4.0.4-7x.18
        librpmio-4.0.4.so   is needed by gnorpm-0.96-14
        librpmio-4.0.4.so   is needed by kdeadmin-3.0.0-4
        librpmio-4.0.4.so   is needed by ucd-snmp-4.2.4-3
        librpmio-4.0.4.so   is needed by rpm-build-4.0.4-7x.18
        librpmio-4.0.4.so   is needed by ucd-snmp-utils-4.2.4-3
        librpmio-4.0.4.so   is needed by rpm-python-4.0.4-7x.18

follow is my db tar file
http://web.holmglad.edu.hk/~hgc-dww/share/rpm.tar.gz

Thank

Moris
Comment 3 Jeff Johnson 2003-05-08 10:35:48 EDT
OK, your database looks fine, all header signatures
verify after importing a the Red Hat public key.

And I'm unable to reproduce the problems you are seeing,
so there's something else that needs fixing.

Does every attempt to install/erase fail, or just
the 2 you mentioned?

Are you using LDAP passwords? Idf so, make sure that
nscd is running.
Comment 4 mortin 2003-05-08 20:53:52 EDT
Yes, every rpm package install,upgrade and erase fail. And this machine is not 
running pamldap. It tried the nscd but without help

BR

Moris
Comment 5 Jeff Johnson 2003-05-09 10:11:53 EDT
Try reinstalling rpm-4.0.4 using rpm2cpio

Download all rpm packages (don't forget popt) into /var/tmp
and do (as root)
    mkdir /var/tmp/xxx
    cd /var/tmp/xxx
    for i in ../*.rpm; do
        rpm2cpio $i | cpio -dim
    done
    find . -type d -exec chmod 755 {} \;
    tar cf - ./* | (cd /; tar xvf -)

Does that correct the segfault?
Comment 6 Jeff Johnson 2003-06-02 10:32:23 EDT
Closed for lack of input.

Note You need to log in before you can comment on or make changes to this bug.