Bug 902698 - Package system-config-kdump not supported on Fedora-18
Package system-config-kdump not supported on Fedora-18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-kdump (Show other bugs)
18
s390x All
unspecified Severity medium
: ---
: ---
Assigned To: Martin Milata
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-01-22 04:50 EST by IBM Bug Proxy
Modified: 2013-10-31 07:15 EDT (History)
11 users (show)

See Also:
Fixed In Version: system-config-kdump-2.0.11-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 01:57:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The screen shot of system-config-kdump execution (177.23 KB, image/png)
2013-01-22 04:50 EST, IBM Bug Proxy
no flags Details
bz87983.patch (438 bytes, text/plain)
2013-01-30 04:50 EST, IBM Bug Proxy
no flags Details
enable on s390x (747 bytes, patch)
2013-06-12 05:29 EDT, Dan Horák
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 87983 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-01-22 04:50:39 EST
Problem Description
-------------------------------------
The Package system-config-kdump does not work on Fedora. When started a dialog box pops up stating:

"Sorry, this architecture does not currently support kdump"

Also there is not kernel-kdump package available for Fedora-18.

Please refer to the attached screenshot.
Comment 1 IBM Bug Proxy 2013-01-22 04:50:50 EST
Created attachment 684967 [details]
The screen shot of system-config-kdump execution
Comment 2 IBM Bug Proxy 2013-01-22 05:30:32 EST
------- Comment From vaish123@in.ibm.com 2013-01-22 10:24 EDT-------
I see that system-config-kdump/src/system-config-kdump.py  has

UNSUPPORTED_ARCHES = ("ppc", "s390", "s390x", "i386", "i586").

I guess the error messages may be due to the following list of unsupported architectures.
Comment 3 IBM Bug Proxy 2013-01-22 05:50:29 EST
------- Comment From vaish123@in.ibm.com 2013-01-22 10:44 EDT-------
(In reply to comment #5)
> I see that system-config-kdump/src/system-config-kdump.py  has
>
> UNSUPPORTED_ARCHES = ("ppc", "s390", "s390x", "i386", "i586").
>
> I guess the error messages may be due to the following list of unsupported
> architectures.

We are already aware of this. The question is "WHY" the s390* platform has chosen to be unsupported for taking kdump? Observing the above line, we can say that system-config-kdump tools is forbidden on any common desktop arches (system p, z, x), and why?
Comment 4 Josh Boyer 2013-01-22 09:07:28 EST
If you figure out this has something to do with the kernel, let us know.  As for now, this should go against the system-config-kdump package.
Comment 5 Roman Rakus 2013-01-22 10:04:43 EST
Thanks for the report.
Removing s390* from unsupported list could probably solve this.
Comment 6 IBM Bug Proxy 2013-01-30 04:50:48 EST
Created attachment 690246 [details]
bz87983.patch


------- Comment on attachment From vaish123@in.ibm.com 2013-01-30 09:43 EDT-------


version of system-config-kdump: system-config-kdump-2.0.10
Comment 7 Dan Horák 2013-06-12 05:16:22 EDT
the bug is still present in system-config-kdump-2.0.11-1.fc19, it seems the patch for enabling s390x support was lost, dropped from the package and not integrated into upstream git
Comment 8 Dan Horák 2013-06-12 05:29:52 EDT
Created attachment 760043 [details]
enable on s390x

refresh patch against current git
Comment 9 Fedora Update System 2013-06-12 06:59:23 EDT
system-config-kdump-2.0.11-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-kdump-2.0.11-2.fc19
Comment 10 Fedora Update System 2013-06-12 06:59:43 EDT
system-config-kdump-2.0.11-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-kdump-2.0.11-2.fc18
Comment 11 Fedora Update System 2013-06-13 01:57:39 EDT
system-config-kdump-2.0.11-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-06-13 02:40:55 EDT
system-config-kdump-2.0.11-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.