This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 902709 - [RHEVM] [upgrade] [backend] upgrade rollback cannot remove files
[RHEVM] [upgrade] [backend] upgrade rollback cannot remove files
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
x86_64 Linux
high Severity medium
: ---
: 3.2.0
Assigned To: Ofer Schreiber
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 05:17 EST by Martin Pavlik
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-21 04:14:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log_collector (925.26 KB, application/x-xz)
2013-01-22 05:17 EST, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-01-22 05:17:56 EST
Created attachment 684998 [details]
log_collector

Description of problem:
After failed upgrade (see bug 902686) from SI26 to SF3 rollback has following complaints

file ovirt-engine-upgrade_2013_01_21_17_08_18.log

2013-01-21 17:09:22::ERROR::rhevm-upgrade::1059::root:: Rolling back update
2013-01-21 17:09:22::ERROR::rhevm-upgrade::562::root:: PKI: cannot remove '/etc/httpd/conf.d/ssl.conf.tmp'
2013-01-21 17:09:22::ERROR::rhevm-upgrade::562::root:: PKI: cannot remove '/etc/pki/ovirt-engine/keys/engine.p12'
2013-01-21 17:09:22::ERROR::rhevm-upgrade::562::root:: PKI: cannot remove '/etc/pki/ovirt-engine/keys/apache.p12'
2013-01-21 17:09:22::ERROR::rhevm-upgrade::562::root:: PKI: cannot remove '/etc/pki/ovirt-engine/apache-ca.pem'
2013-01-21 17:09:22::ERROR::rhevm-upgrade::562::root:: PKI: cannot remove '/etc/pki/ovirt-engine/certs/apache.cer'
2013-01-21 17:09:22::ERROR::rhevm-upgrade::562::root:: PKI: cannot remove '/etc/pki/ovirt-engine/keys/apache.key.nopass'

It seems that files actually do not exist in the system

Version-Release number of selected component (if applicable):
updgrade from SI26 to SF3

How reproducible:
100%

Steps to Reproduce:
1. upgrade from si26 to sf3, upgrade will fail on database upgrade (see bug 902686)
  
Actual results:
rollback throws errors about files that cannot be removed - it seems that files do not exist in the system

Expected results:
rollback without errors

Additional info:
Comment 1 Moran Goldboim 2013-02-27 17:26:24 EST
Martin, any user impact beside ERROR log massages?
Comment 2 Martin Pavlik 2013-03-01 02:58:00 EST
I don't think there was some other impact.
Comment 3 Ofer Schreiber 2013-04-14 07:59:16 EDT
In RHEV-3.2, we changed our PKI infrastracture, and separated apache and ca keys.
This means that during the upgrade from 3.1, We're creating those files specifically.

In any case the 3.1 -> 3.2  upgrade fails, we're removing those files we creating.
In this case, we're trying to remove those files, but since the upgrade didn't created them yet, it logs the failure.

As those "Errors" in the log are just information for anyone that would like to debug the upgrade/rollback, I see no reason we should change this.

I'd recommend closing this issue as not a bug (or, change the log, which I'm not sure is necessary).

Note You need to log in before you can comment on or make changes to this bug.