Bug 902732 - [abrt] mate-panel-1.5.3-1.fc19: dconf_engine_change_completed: Process /usr/bin/mate-panel was killed by signal 6 (SIGABRT)
Summary: [abrt] mate-panel-1.5.3-1.fc19: dconf_engine_change_completed: Process /usr/b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-panel
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e648edb76dad3c8f96cf283d65f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-22 11:06 UTC by Aioanei Rares
Modified: 2013-03-12 08:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 08:44:46 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (21.35 KB, text/plain)
2013-01-22 11:06 UTC, Aioanei Rares
no flags Details
File: build_ids (3.76 KB, text/plain)
2013-01-22 11:06 UTC, Aioanei Rares
no flags Details
File: cgroup (129 bytes, text/plain)
2013-01-22 11:06 UTC, Aioanei Rares
no flags Details
File: core_backtrace (2.24 KB, text/plain)
2013-01-22 11:06 UTC, Aioanei Rares
no flags Details
File: dso_list (8.53 KB, text/plain)
2013-01-22 11:06 UTC, Aioanei Rares
no flags Details
File: environ (1.46 KB, text/plain)
2013-01-22 11:07 UTC, Aioanei Rares
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-22 11:07 UTC, Aioanei Rares
no flags Details
File: maps (45.32 KB, text/plain)
2013-01-22 11:07 UTC, Aioanei Rares
no flags Details
File: open_fds (930 bytes, text/plain)
2013-01-22 11:07 UTC, Aioanei Rares
no flags Details
File: proc_pid_status (930 bytes, text/plain)
2013-01-22 11:07 UTC, Aioanei Rares
no flags Details
File: var_log_messages (471 bytes, text/plain)
2013-01-22 11:07 UTC, Aioanei Rares
no flags Details

Description Aioanei Rares 2013-01-22 11:06:44 UTC
Description of problem:
Just started MATE in a VM.

Version-Release number of selected component:
mate-panel-1.5.3-1.fc19

Additional info:
backtrace_rating: 4
cmdline:        mate-panel
crash_function: dconf_engine_change_completed
executable:     /usr/bin/mate-panel
kernel:         3.8.0-0.rc4.git1.1.fc19.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (9 frames)
 #4 dconf_engine_change_completed at dconf-engine.c:893
 #5 dconf_gdbus_method_call_done at dconf-gdbus-thread.c:230
 #6 g_simple_async_result_complete at gsimpleasyncresult.c:777
 #7 g_dbus_connection_call_done at gdbusconnection.c:5333
 #8 g_simple_async_result_complete at gsimpleasyncresult.c:777
 #9 complete_in_idle_cb at gsimpleasyncresult.c:789
 #13 g_main_context_iteration at gmain.c:3420
 #14 dconf_gdbus_worker_thread at dconf-gdbus-thread.c:81
 #15 g_thread_proxy at gthread.c:798

Comment 1 Aioanei Rares 2013-01-22 11:06:47 UTC
Created attachment 685044 [details]
File: backtrace

Comment 2 Aioanei Rares 2013-01-22 11:06:49 UTC
Created attachment 685045 [details]
File: build_ids

Comment 3 Aioanei Rares 2013-01-22 11:06:53 UTC
Created attachment 685046 [details]
File: cgroup

Comment 4 Aioanei Rares 2013-01-22 11:06:55 UTC
Created attachment 685047 [details]
File: core_backtrace

Comment 5 Aioanei Rares 2013-01-22 11:06:58 UTC
Created attachment 685048 [details]
File: dso_list

Comment 6 Aioanei Rares 2013-01-22 11:07:00 UTC
Created attachment 685049 [details]
File: environ

Comment 7 Aioanei Rares 2013-01-22 11:07:02 UTC
Created attachment 685050 [details]
File: limits

Comment 8 Aioanei Rares 2013-01-22 11:07:04 UTC
Created attachment 685051 [details]
File: maps

Comment 9 Aioanei Rares 2013-01-22 11:07:08 UTC
Created attachment 685052 [details]
File: open_fds

Comment 10 Aioanei Rares 2013-01-22 11:07:10 UTC
Created attachment 685053 [details]
File: proc_pid_status

Comment 11 Aioanei Rares 2013-01-22 11:07:12 UTC
Created attachment 685054 [details]
File: var_log_messages

Comment 12 Dan Mashal 2013-01-23 02:43:17 UTC
Please run yum update and reopen this bug if you still experience issues.

Comment 13 Aioanei Rares 2013-01-23 09:20:52 UTC
Yes, the bug is still there after the update. Why close the bug and especially why NOTABUG?

Comment 14 Dan Mashal 2013-01-29 08:15:58 UTC
Sorry. What are the steps to reproduce?

Comment 15 Endre "Hrebicek" Balint-Nagy 2013-02-08 18:49:20 UTC
I meet this bug too. In the beginning MATE started to work but recently mate-panel is chrashing repeatedly each time when I log in intro a MATE session.
Gnome3 works, but I am a passionate gnome3 hater. This bug locks me back to RHEL6 and Gnome2. I am intended to switch to F18/MATE as it becomes stable.

Do you need some files? (I have 24 abrt directories with component=mate-panel)

Cheers:
Endre/Ondra

Comment 16 Dan Mashal 2013-02-11 12:48:28 UTC
(In reply to comment #15)
> I meet this bug too. In the beginning MATE started to work but recently
> mate-panel is chrashing repeatedly each time when I log in intro a MATE
> session.
> Gnome3 works, but I am a passionate gnome3 hater. This bug locks me back to
> RHEL6 and Gnome2. I am intended to switch to F18/MATE as it becomes stable.
> 
> Do you need some files? (I have 24 abrt directories with
> component=mate-panel)
> 
> Cheers:
> Endre/Ondra

Hopefully mate-window-manager-1.5.3-3.fc18 helps.

And MATE on F18 is pretty darn stable.

There are a round of MATE updates coming shortly via upstream.

Comment 17 Fedora Update System 2013-02-11 12:49:12 UTC
mate-window-manager-1.5.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-1671/mate-window-manager-1.5.3-3.fc18

Comment 18 Endre "Hrebicek" Balint-Nagy 2013-02-11 20:26:41 UTC
mate-window-manager-1.5.3-3.fc18 is installed, and a new mwm session appeared in the gdm session menu.
When I choose MATE, get the mate-panel dying syndrome.
When I choose Mwm, I am getting a single window probably the workspace selector or alike. With right-clicking on the root window, I got some menu, clicking on the new window I got a terminal window.
typing mate-session resulted in the mate-panel crashing syndrome again.
So I am confused. Can you give some hint on resolving the issue. (My first idea to remove temporarily all window managers except mwm. Maybe I will try it tonight - Brno time, thus CET.)

Comment 19 Endre "Hrebicek" Balint-Nagy 2013-02-11 22:35:20 UTC
Which is the right display manager for mate?
It is crashing with lightdm and gdm.
Perhaps my home directory wrt mate is screwed up?!
(I run gnome2 (from RHEL6) and gnome3 (from F18) and seen some MATE migration tool in my session startup even without asking for it.)
I'll try to rename anll mate specific directories in my home as next step.

Comment 20 Endre "Hrebicek" Balint-Nagy 2013-02-11 22:43:49 UTC
renaming .mateconf  to ,mateconf ,
         .mateconfd to ,mateconfd
not changed anything, mate-panel still crashed.
Will retry yum reinstall @mate again.

Comment 21 Endre "Hrebicek" Balint-Nagy 2013-02-11 23:05:13 UTC
No luck. BTW this time gnome3 come up with Applications instead of Activities - the most hated Gnome3 component.
Maybe I can give up hopes and go the gome3 way?

Comment 22 Endre "Hrebicek" Balint-Nagy 2013-02-11 23:15:33 UTC
I left out (among other seeming unnecessary) features from kernel:
extfs4 (a braindamage for desktops like btrfs but less crappy)
ipv6 (my WL-1500R has no ipv6 support at all)
fuse (a resource hog, I prefer in-kernel filesystems instead of the userspace)
Any of them is a must for MATE?
Ondra

Comment 23 Fedora Update System 2013-02-12 05:03:32 UTC
mate-window-manager-1.5.3-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Dan Mashal 2013-02-12 12:28:48 UTC
I just realized you're running rawhide and asking for stability. Please yum downgrade mate-panel. The recent updates to libmatkbd, mate-panel, etc. etc. not worth it. Use what's in F18.

Comment 25 Endre "Hrebicek" Balint-Nagy 2013-02-13 02:33:38 UTC
Sorry I misdirected by bug a bit.
Here is my environment:
[bne@panther ~]$ cat /etc/redhat-release 
Fedora release 18 (Spherical Cow)

[bne@panther ~]$ uname -r
3.7.4-pinky

So (f18) 3.7.4 based cut-down kernel.

[bne@panther ~]$ rpm -q mate-panel
mate-panel-1.5.4-1.fc18.x86_64


[bne@panther ~]$ sudo yum repolist enabled
Loaded plugins: langpacks, presto, refresh-packagekit
repo id                                                                   repo name                                                                     status
adobe-linux-x86_64                                                        Adobe Systems Incorporated                                                        2
beaker-client/18                                                          Beaker Client - Fedora18                                                         18
fedora/18/x86_64                                                          Fedora 18 - x86_64                                                            33868
google-chrome                                                             google-chrome                                                                     3
qa-tools                                                                  QA Tools Incubator                                                              207
rhpkg/18                                                                  rhpkg for Fedora 18                                                               9
updates/18/x86_64                                                         Fedora 18 - x86_64 - Updates                                                  10827
updates-testing/18/x86_64                                                 Fedora 18 - x86_64 - Test Updates                                             13967
updates-testing-debuginfo/18/x86_64                                       Fedora 18 - x86_64 - Test Updates Debug                                        1728
repolist: 60629

And mate-panel is steadily crashing.


So re-address my complaints to F18 released, please.
(I have no intention to sit on the bleeding edge...)

Comment 26 Endre "Hrebicek" Balint-Nagy 2013-02-15 15:32:36 UTC
In the end I persuaded  mate-session to start 
with this .xinitrc file
#!/bin/bash
export LANG=en_US.utf8
exec mate-session
and ran startx
(in english, not german as MATE decided when started trough gdm), now I feel a bit better.
lightdm was crashing, had to switch to gnome, but after the first login the session selection disappeared and swicthed the locale to German.
While I am not completely frustrated with German - Ja, ich spreche ein wenigh Deutch - hard to say I am satisfied with it.

My efforts to install a fresh F18 failed, while I wanted to start with a clean install as this copy was made trough F17 in F18Beta time and there are no miracles, it has some issues.
Endre/Ondras

Comment 27 Endre "Hrebicek" Balint-Nagy 2013-02-20 23:29:31 UTC
Looks like I understood the issue in the end.
By removing the mate-file-manager I made my mate-desktop unusable, however IMHO
any file manager is only an optional part of an x-session - consider the security aspects - , and the crash of mate-panel in this case is a bug, and probably means some mate-panel related file is in mate-file-manager or in in a package depending on it like mate-vfs. ( I removed the startuo of file-manager from my startup, and it is functional without it but must be installed ATM)
(BTW the same is true for Gnome3, but gnome2 is exempt of this issue.)

Endre/Ondras.

Comment 28 Fedora Update System 2013-03-03 22:57:10 UTC
mate-panel-1.5.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-panel-1.5.5-1.fc18

Comment 29 Fedora Update System 2013-03-04 22:30:48 UTC
Package mate-panel-1.5.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-panel-1.5.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3387/mate-panel-1.5.5-1.fc18
then log in and leave karma (feedback).

Comment 30 Fedora Update System 2013-03-12 08:44:48 UTC
mate-panel-1.5.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.