Bug 902796 - audacious crash when AOSD plugin is loaded
Summary: audacious crash when AOSD plugin is loaded
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious-plugins
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-22 12:24 UTC by GV
Modified: 2013-02-02 04:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-02 04:24:43 UTC


Attachments (Terms of Use)

Description GV 2013-01-22 12:24:52 UTC
Description of problem:
audacious in F18 crash when AOSD plugin is loaded.

Version-Release number of selected component (if applicable):
audacious-3.3.3-1.fc18.x86_64
audacious-plugins-3.3.3-1.fc18.x86_64

Steps to Reproduce:
1. start audacious
2. enable AOSD plugin
3.
  
Actual results:
audacious crash

Expected results:
AOSD plugin should be loaded or at least an error message that AOSD plugin cannot be loaded.

Comment 1 Michael Schwendt 2013-01-22 12:37:22 UTC
Cannot reproduce.

Attach the full output of "audacious -V" when starting it within a terminal. Also attach the backtrace, which ABRT (abrt-gui) should have caught automatically, btw.

Comment 2 GV 2013-01-22 13:01:58 UTC
The problem seem to be in the config file in [aosd] section.
Up to F17 I had:

trigger_active=0,1,2,3,4

Now there are only 4 triggers so the line should be 

trigger_active=0,1,2,3

I'm not sure, but it seems like somewhere in the source files, one does not check the number of triggers.

This is the whole section:

[aosd]
position_placement=7
position_offset_x=100
position_offset_y=0
position_maxsize_width=0
position_multimon_id=-1
animation_timing_display=5000
animation_timing_fadein=300
animation_timing_fadeout=300
text_fonts_name_0=Serif 32
text_fonts_color_0=65535,0,0,65535
text_fonts_draw_shadow_0=TRUE
text_fonts_shadow_color_0=0,0,0,32767
text_utf8conv_disable=FALSE
decoration_code=3
decoration_color_0=0,0,65535,32767
decoration_color_1=65535,65535,65535,65535
trigger_active=0,1,2,3,4
transparency_mode=0

Comment 3 Michael Schwendt 2013-01-22 14:12:15 UTC
Obviously. Thanks for the detective work!

The trigger config constants have changed between Audacious 3.2.4 and 3.3. One trigger constant has been removed, the other ones have been lowered by one. That causes several parts of the AOSD plug-in crash during array out-of-bounds access.

Comment 4 Michael Schwendt 2013-01-22 14:25:29 UTC
I've forwarded the bug report upstream: http://redmine.audacious-media-player.org/issues/243

Since there is a work-around (editing the config file) and Audacious 3.3.x at Fedora has passed the development and testing period without anyone reporting this problem before, I'll wait for a response from upstream before releasing an update. There are several ways how to fix this.

Comment 5 GV 2013-01-22 15:32:44 UTC
Sounds fine. Thank you.

Comment 6 Fedora Update System 2013-01-23 10:34:23 UTC
audacious-plugins-3.3.3-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/audacious-plugins-3.3.3-4.fc18

Comment 7 GV 2013-01-23 21:27:28 UTC
Thank you. Works fine.

Comment 8 Fedora Update System 2013-01-24 22:36:27 UTC
Package audacious-plugins-3.3.3-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audacious-plugins-3.3.3-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1436/audacious-plugins-3.3.3-4.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-02-02 04:24:45 UTC
audacious-plugins-3.3.3-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.