Bug 902799 - RFE: Editor option to invert the TM diff shading
RFE: Editor option to invert the TM diff shading
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
3.7
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Luke Brooker
Zanata-QA Mailling List
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 07:28 EST by Nilamdyuti
Modified: 2016-04-18 05:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 21:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Translatiom memory suggestion for a 96% match showing the entry to be removed and that to be added to make it 100% match for the source string. (65.48 KB, image/png)
2013-01-22 07:38 EST, Nilamdyuti
no flags Details

  None (edit)
Description Nilamdyuti 2013-01-22 07:28:10 EST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build Identifier: 

Whenever a particular string is selected for translation at the editor, the corresponding translation memory suggestions that are displayed on the TM window always shows the entry that is to be inserted to make it a 100% match for the target string as "strike out" and red in colour and the entry to be removed in blue colour. To elaborate, if a TM suggestion is giving 96% match and requires only a single word to be removed and a new word to be inserted in it's place to make it a 100% match, the word to be inserted is shown as "strike out" and red in colour and the word to be removed is shown in blue colour whereas it should have been the other way around, i.e, "strike out" and red for the entry to be removed and blue for the one to be inserted to make it a 100% match. I will attach a screenshot after this bug is filed so that the issue can be understood better. 

Zanata version: 2.0.3


Reproducible: Always

Steps to Reproduce:
1. Login into Zanata
2. Open a project and go to the editor.
3. Select a string a look for TM suggestions which are less than 100% match.
4. Look for the entries that need to be inserted or removed to make a 100% match.
Actual Results:  
The entry to be inserted is shown as "strike out" and red in colour and the entry to be removed is shown in blue colour.

Expected Results:  
The entry to be inserted should be shown in blue and the entry to be removed as "strike out" and red in colour.

This issue has been there in earlier versions too. I have provided the version as 2.0 owing to the current version that I am using which is 2.0.3. If the version number needs to be changed for this bug, kindly do the same.
Comment 1 Nilamdyuti 2013-01-22 07:38:12 EST
Created attachment 685108 [details]
Translatiom memory suggestion for a 96% match showing the entry to be removed and that to be added to make it 100% match for the source string.

Here in this attachment "Release Notes" are the words that need to be inserted and are shown as "strike out" and red in colour whereas "&Book" is the entry which is to be removed and is shown in blue colour.
Comment 2 Sean Flanigan 2013-01-23 21:03:58 EST
Runa, does this mean that Zanata's diff highlighting is the other way around, compared to Lokalize and KBabel?

If we do change this, we may need to make it an editor option, because some users may be used to the current behaviour.
Comment 3 Carlos Munoz 2013-01-28 17:06:18 EST
Sean, I agree with the editor option and I stressed this exact point to Runa and Nilamdyuti. Also, as I understood it, the issue is more with the strike-through than it is with the colors being used.

I think for us it just means that we would need to change the "source" of the diff, but again, some users might already be used to what's currently there.
Comment 4 Sean Flanigan 2013-10-21 22:13:34 EDT
Is Zanata's diff highlighting the other way around, compared to Lokalize and KBabel?
Comment 5 Nilamdyuti 2013-10-22 03:33:56 EDT
Hi Sean,

Yes, Zanata's diff highlighting is other way around compared to Lokalize and KBabel. In Lokalize, the to be inserted string in diff highlighting is shown in blue color and the to be removed string in red whereas in Zanata's diff highlighting, the to be inserted string is shown in red and it is striked out and the to be removed string is in blue color and without any strike.
Comment 6 Michelle Kim 2015-03-30 19:43:48 EDT
Let's change the colours. Assigning to Luke to come up with better highlighting. Aiming to release it in next release 3.7
Comment 7 Zanata Migrator 2015-07-30 21:18:43 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-421

Note You need to log in before you can comment on or make changes to this bug.