Bug 902883 - After fedup upgrade to 18 from 17, xend.service was disabled
After fedup upgrade to 18 from 17, xend.service was disabled
Status: CLOSED DUPLICATE of bug 893699
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 10:41 EST by Lloyd Kvam
Modified: 2013-01-24 08:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-23 18:56:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lloyd Kvam 2013-01-22 10:41:02 EST
Description of problem:
After upgrading to Fedora 18, virt-manager and other virtualization related commands did not work. 

virsh list --all returned:
ERROR    unable to connect to 'localhost:8000': Connection refused

xendomain, xenconsoled, and xenstoraged were still enabled and running.  It took me a while to realize the problem was easily solved by simply starting (and enabling) xend.

Version-Release number of selected component (if applicable):


How reproducible:
Since it was the result of the upgrade, it's hard to reproduce.  I am mostly hoping to document my experience for others.  Whatever caused xend to be disabled my be quite obscure.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Easily diagnosed by:
systemctl is-enabled xend.service 

If disabled and not started:
systemctl enable xend.service 
systemctl start xend.service
Comment 1 Will Woods 2013-01-23 11:18:16 EST
fedup does not directly touch any services. All it does is install packages. 

If you're having a problem with xend, this is a bug with the xen package, or some other package that disabled xend.service.

Reassigning to xen.
Comment 2 Michael Young 2013-01-23 18:56:43 EST
xend.service was probably disabled in your Fedora 17 as well so fedup didn't change anything. You didn't notice this as there is a bug in Fedora 17 which means libvirt starts xend rather than checking it is running.

In Fedora 18 changes to libvirt means that it notices something strange is happening and reports that xend isn't running (when technically it is).

These issues with xend and libvirt in Fedora 18 are being dealt with in Bug 893699.

*** This bug has been marked as a duplicate of bug 893699 ***
Comment 3 Lloyd Kvam 2013-01-24 08:50:50 EST
(In reply to comment #2)
> xend.service was probably disabled in your Fedora 17 as well so fedup didn't
> change anything. You didn't notice this as there is a bug in Fedora 17 which
> means libvirt starts xend rather than checking it is running.
> 
> In Fedora 18 changes to libvirt means that it notices something strange is
> happening and reports that xend isn't running (when technically it is).
> 
> These issues with xend and libvirt in Fedora 18 are being dealt with in Bug
> 893699.
> 
> *** This bug has been marked as a duplicate of bug 893699 ***

Thanks for the explanation.

Note You need to log in before you can comment on or make changes to this bug.