Bug 902884 - [abrt] libreoffice-core-3.6.3.2-8.fc18: SdrPage::getUnoPage: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.6.3.2-8.fc18: SdrPage::getUnoPage: Process /usr/lib...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:1ec00492b6bcbd32d50bae551ee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 10:44 EST by Jeremy Eder
Modified: 2013-03-13 22:57 EDT (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-3.6.5.2-6.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 22:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 12 David Tardon 2013-01-24 09:19:55 EST
It crashed when you tried to edit a master page. Is the crash reproducible?
Comment 15 David Tardon 2013-02-04 10:00:14 EST
No luck here. a11y does not have any effect either.
Comment 16 Caolan McNamara 2013-02-15 09:28:58 EST
Nothing with repeated attempts. ToDo: retry under valgrind
Comment 17 Caolan McNamara 2013-03-07 11:13:34 EST
Nothing reported under valgrind. Works for me fine, and there's no indication in the bt that GetSelectedMasterPage returns NULL there but it must have returned something bogus to crash there. All very mysterious.

GetSelectedMasterPage can in theory return NULL, so fixed that code to be stable in the face of that happening on the off chance that optimization has led gdb to report that variable as a non-NULL value which actually being NULL.
Comment 18 Fedora Update System 2013-03-07 15:58:18 EST
libreoffice-3.6.5.2-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libreoffice-3.6.5.2-6.fc18
Comment 19 Fedora Update System 2013-03-08 18:57:09 EST
Package libreoffice-3.6.5.2-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.6.5.2-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3597/libreoffice-3.6.5.2-6.fc18
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2013-03-13 22:57:53 EDT
libreoffice-3.6.5.2-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.