Bug 902887 - [abrt] libvirt-daemon-0.10.2.2-3.fc18: virDomainDefFree: Process /usr/sbin/libvirtd was killed by signal 11 (SIGSEGV)
[abrt] libvirt-daemon-0.10.2.2-3.fc18: virDomainDefFree: Process /usr/sbin/li...
Status: CLOSED DUPLICATE of bug 877110
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
abrt_hash:b2d7c75f2958514dfed5733aead...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 10:57 EST by Richard W.M. Jones
Modified: 2013-01-28 17:42 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-28 17:42:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (56.55 KB, text/plain)
2013-01-22 10:57 EST, Richard W.M. Jones
no flags Details
File: build_ids (3.80 KB, text/plain)
2013-01-22 10:57 EST, Richard W.M. Jones
no flags Details
File: cgroup (129 bytes, text/plain)
2013-01-22 10:57 EST, Richard W.M. Jones
no flags Details
File: core_backtrace (1.65 KB, text/plain)
2013-01-22 10:57 EST, Richard W.M. Jones
no flags Details
File: dso_list (9.20 KB, text/plain)
2013-01-22 10:58 EST, Richard W.M. Jones
no flags Details
File: environ (518 bytes, text/plain)
2013-01-22 10:58 EST, Richard W.M. Jones
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-22 10:58 EST, Richard W.M. Jones
no flags Details
File: maps (715.18 KB, text/plain)
2013-01-22 10:58 EST, Richard W.M. Jones
no flags Details
File: open_fds (887 bytes, text/plain)
2013-01-22 10:58 EST, Richard W.M. Jones
no flags Details
File: proc_pid_status (931 bytes, text/plain)
2013-01-22 10:58 EST, Richard W.M. Jones
no flags Details
File: var_log_messages (11.59 KB, text/plain)
2013-01-22 10:58 EST, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2013-01-22 10:57:44 EST
Description of problem:
I didn't do anything.  libvirtd appeared to crash after I logged in.

Version-Release number of selected component:
libvirt-daemon-0.10.2.2-3.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/sbin/libvirtd --timeout=30
crash_function: virDomainDefFree
executable:     /usr/sbin/libvirtd
kernel:         3.6.9-4.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 virDomainDefFree at conf/domain_conf.c:1626
 #1 virDomainObjDispose at conf/domain_conf.c:1737
 #2 virObjectUnref at util/virobject.c:139
 #3 qemuDomainObjEndJob at qemu/qemu_domain.c:943
 #4 qemuDomainDestroyFlags at qemu/qemu_driver.c:1996
 #5 virDomainDestroyFlags at libvirt.c:2264
 #6 remoteDispatchDomainDestroyFlags at remote_dispatch.h:1329
 #7 remoteDispatchDomainDestroyFlagsHelper at remote_dispatch.h:1307
 #8 virNetServerProgramDispatchCall at rpc/virnetserverprogram.c:431
 #9 virNetServerProgramDispatch at rpc/virnetserverprogram.c:304
Comment 1 Richard W.M. Jones 2013-01-22 10:57:49 EST
Created attachment 685266 [details]
File: backtrace
Comment 2 Richard W.M. Jones 2013-01-22 10:57:51 EST
Created attachment 685267 [details]
File: build_ids
Comment 3 Richard W.M. Jones 2013-01-22 10:57:57 EST
Created attachment 685268 [details]
File: cgroup
Comment 4 Richard W.M. Jones 2013-01-22 10:57:59 EST
Created attachment 685269 [details]
File: core_backtrace
Comment 5 Richard W.M. Jones 2013-01-22 10:58:02 EST
Created attachment 685270 [details]
File: dso_list
Comment 6 Richard W.M. Jones 2013-01-22 10:58:09 EST
Created attachment 685271 [details]
File: environ
Comment 7 Richard W.M. Jones 2013-01-22 10:58:24 EST
Created attachment 685272 [details]
File: limits
Comment 8 Richard W.M. Jones 2013-01-22 10:58:35 EST
Created attachment 685273 [details]
File: maps
Comment 9 Richard W.M. Jones 2013-01-22 10:58:37 EST
Created attachment 685274 [details]
File: open_fds
Comment 10 Richard W.M. Jones 2013-01-22 10:58:40 EST
Created attachment 685275 [details]
File: proc_pid_status
Comment 11 Richard W.M. Jones 2013-01-22 10:58:45 EST
Created attachment 685276 [details]
File: var_log_messages
Comment 12 Richard W.M. Jones 2013-01-22 11:00:05 EST
Since ABRT just popped up immediately after I logged in,
and I wasn't using libvirt at all, I suspect this bug is
just something that ABRT pulled out of its guts at random
and decided to submit.
Comment 13 Cole Robinson 2013-01-28 17:42:23 EST
I'm just gonna assume this is related to the destroy() race since the backtrace is close.

*** This bug has been marked as a duplicate of bug 877110 ***

Note You need to log in before you can comment on or make changes to this bug.