Bug 90292 - rpm hangs while -Uvh in Shrike
rpm hangs while -Uvh in Shrike
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rpm (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 11:34 EDT by aron vrtala
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-06 12:37:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aron vrtala 2003-05-06 11:34:48 EDT
Description of problem:

After several days of regular operation, rpm now hangs when trying to
update/install any kind of package. The % Update List reads 100% installed.
After killing rpm process and releasing locks the package will not be
listed in rpm -qa.

Version-Release number:  Standard rpm package with Shrike.

How reproducible: Now at any rate. I also tried rpm -Uvvvh blah  and it
hangs at GZDIO:     250 reads,  2040148 total bytes in 0.000 secs.

The % Update List is 100% installed. After killing rpm process and releasing locks

Steps to Reproduce:
1. Problem reoccurs also after reboot.
2. rpm -Uvh any_new_package
3.
    
Additional info:
I've seen in Bugzilla #74726 (now status closed) the same for Psyche.

Thank you in advance, Aron
Comment 1 Jeff Johnson 2003-05-06 12:37:05 EDT
Yes, same as #74726, but the root causes are very, very different.

Do
    rm -f /var/lib/rpm/__db*
and upgrade to rpm-4.2-1 packages from
    ftp://ftp.rpm.org/pub/rpm/test-4.2
is the answer. (Assuming Red Hat 9, use rpm-4.1.1 if Red Hat 8.0)

Note You need to log in before you can comment on or make changes to this bug.