This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 90300 - xterm outputs diaeresis instead of double quotes.
xterm outputs diaeresis instead of double quotes.
Status: CLOSED DUPLICATE of bug 84802
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 12:22 EDT by Hans Deragon
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans Deragon 2003-05-06 12:22:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Description of problem:
When $LANG is set to "en_CA.UTF-8" and the keyboard layout is set for dead keys,
such as the following setting:

  Option      "XkbLayout" "us_intl"

...in XF86Config's InputDevice section, instead of double quotes showing up when
<double quotes><space> are pressed in sequence, diaeresis are showing up.  This
is wrong.  Double quotes are expected and required.

This does not occure with the gnome-terminal, but only with xterm.


Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
To reproduce:

export LANG=en_CA.UTF-8
xmodmap - <<EOF
keycode  48 = dead_acute dead_diaeresis apostrophe quotedbl
EOF
xterm&

Now in the newly created xterm, press the double quote key (<shift-apostrophe>)
followed by a space.  Notice the character comming out.  Altough it looks like
one, its not a double quote.  You can test it by doing:

  echo "This sentence should not appear double quoted."

The normal behavior when surrounded by double quotes would output:

  This sentence should not appear double quoted.

What you will get is:

  ¨This sentence should not appear double quoted¨

P.S.  Its possible that bugzilla does not support internationalization, thus ?
could show up instead of the diaeresis in the last output.  Sorry, I can't do
anything about that.
Comment 1 Mike A. Harris 2003-05-07 03:12:47 EDT
Most likely, this is not an xterm problem, but is either an xkb related
bug, or some kind of misconfiguration of xkb.  Please report this bug
upstream to http://bugs.xfree86.org  This is the fastest possible way to find
a solution to xkb related issues.

You may also wish to discuss the problem on xfree86@xfree86.org to see if
anyone knowledgeable about xkb has any ideas.

After reporting your bug upstream, paste the upstream bug report
URL here and I will track it.
Comment 2 Didier 2003-05-16 04:28:55 EDT
I guess this bug is a duplicate of bug #84802 (cfr. comment
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=84802#c12).
Comment 3 Mike A. Harris 2003-05-16 04:49:41 EDT

*** This bug has been marked as a duplicate of 84802 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:52:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.