This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 903058 - SSLTimeoutError in the /var/log/rhsm/rhsm.log
SSLTimeoutError in the /var/log/rhsm/rhsm.log
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity urgent
: rc
: 1.3
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-01-22 22:29 EST by Hui Wang
Modified: 2013-10-01 07:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:03:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2013-01-22 22:29:27 EST
Description of problem:
Refresh SAM web ui, it will report SSLTimeoutError.

Version-Release number of selected component (if applicable):
virt-who-0.8-5.el6
subscription-manager-1.1.22-1.el6.x86_64
katello-headpin-1.2.1-14h.el6_3.noarch
candlepin-0.7.23-1.el6_3.noarch
RHEL6.4-server-x86_64-20130116.3 + RHEVM3.1.2

How reproducible:
100%

Step to Reproduce:


1. Prepared two rhel6.4 hosts(Host1, Host2)
2. Add the two rhel6.4 host to rhevm3.1.2
3. Prepared the third rhel6.4(Host3) which is running virt-who
4. Config the virt-who on rhel64 (Host3) that in step3
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=10
VIRTWHO_RHEVM=1
VIRTWHO_RHEVM_OWNER=ACME_Corporation
VIRTWHO_RHEVM_ENV=env1
VIRTWHO_RHEVM_SERVER=https://10.66.78.45:443
VIRTWHO_RHEVM_USERNAME=admin@internal
VIRTWHO_RHEVM_PASSWORD=redhat
5. Restart virt-who on Host3, then Host1 and Host2 registered to SAM 

6. Add guest to Host1 or Host2, then refresh the SAM Web UI (systems-->choose  host1 or host2-->Details-->systeminfo)

7. Check the virt-who report log in /var/log/rhsm/rhsm.log 

2013-01-23 10:48:48,873 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {'3e30c294-614f-11e2-a861-8f46739113c1': [], '632528b0-6375-11e2-8205-a7a1dc19b6cf': ['789dfeab-3ddb-4ae6-920b-760147bc8b2e', '45186afa-e19f-44b2-a305-098e702c0bd7'], 'cb918328-6378-11e2-9641-c78c8a96a1b5': ['79e1deab-45bd-4db0-a47a-08a9cec57648', '582fa39c-8971-4fce-91b8-23fcf6806d34']}
2013-01-23 10:49:48,957 [ERROR]  @virt-who.py:212 - Error in communication with subscription manager, trying to recover:
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 196, in _send
    result = self.subscriptionManager.hypervisorCheckIn(self.options.owner, self.options.env, virtualGuests)
  File "/usr/share/virt-who/subscriptionmanager.py", line 92, in hypervisorCheckIn
    return self.connection.hypervisorCheckIn(owner, env, mapping)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 627, in hypervisorCheckIn
    return self.conn.request_post(url, host_guest_mapping)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 440, in request_post
    return self._request("POST", method, params)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 389, in _request
    response = conn.getresponse()
  File "/usr/lib64/python2.6/httplib.py", line 990, in getresponse
    response.begin()
  File "/usr/lib64/python2.6/httplib.py", line 391, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.6/httplib.py", line 349, in _read_status
    line = self.fp.readline()
  File "/usr/lib64/python2.6/socket.py", line 433, in readline
    data = recv(1)
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 228, in read
    return self._read_bio(size)
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 213, in _read_bio
    return m2.ssl_read(self.ssl, size, self._timeout)
SSLTimeoutError


Actual results:
As above

Expected results:
No the error info.
Comment 1 Devan Goodwin 2013-08-09 11:21:07 EDT
Can we get katello-debug output for this?
Comment 2 Liushihui 2013-08-12 05:15:45 EDT
Hi , Devan

I checked this bug with the RHEL6.4-server-x86_64-20130130 + RHEVM3.2 + SAM-1.3-20130624.0 but can't reproduce it again, please see below testing details, so I think this bug may be fixed in SAM1.3, if you also think so, please move this bug status to "ON_QA", I will close this bug then.

Test enviorment:
subscription-manager-1.1.23-1.el6.x86_64
python-rhsm-1.1.8-1.el6.x86_64
virt-who-0.8-5.el6.noarch
katello-headpin-1.4.2-17.el6sam_splice.noarch
candlepin-0.8.9-1.el6_4.noarch
RHEL6.4-server-x86_64-20130130 + RHEVM3.2 + SAM-1.3-20130624.0

Test steps:
1. Prepared two rhel6.4 hosts(Host1, Host2)
2. Add the two rhel6.4 host to rhevm3.2
3. Prepared the third rhel6.4(Host3) which is running virt-who
4. Config the virt-who on rhel64 (Host3) that in step3
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=10
VIRTWHO_RHEVM=1
VIRTWHO_RHEVM_OWNER=ACME_Corporation
VIRTWHO_RHEVM_ENV=env1
VIRTWHO_RHEVM_SERVER=https://10.66.78.46:443
VIRTWHO_RHEVM_USERNAME=admin@internal
VIRTWHO_RHEVM_PASSWORD=redhat

5. Restart virt-who on Host3, then Host1 and Host2 registered to SAM 

6. Add guest to Host1 or Host2, then refresh the SAM Web UI (systems-->choose  host1 or host2-->Details-->systeminfo)

7. Check the virt-who report log in /var/log/rhsm/rhsm.log

Testing Result:
There isn't any error log described in this bug appears in rhsm.log

Thanks,
Shihui Liu

(In reply to Devan Goodwin from comment #1)
> Can we get katello-debug output for this?
Comment 3 Devan Goodwin 2013-08-12 13:35:30 EDT
Yeah seems unlikely this could still be around, lets ON_QA it. Thanks Liushihu.
Comment 4 Li Bin Liu 2013-08-14 08:54:38 EDT
According to the Comment 2 and Comment 3, move the status to VERIFIED.

Thanks,
Libin
Comment 6 errata-xmlrpc 2013-10-01 07:03:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.