This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 903219 - [REST-API] NPE in api?rsdl
[REST-API] NPE in api?rsdl
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.2.0
Assigned To: Ravi Nori
Jakub Libosvar
infra
: Regression
Depends On:
Blocks: 872819
  Show dependency treegraph
 
Reported: 2013-01-23 09:12 EST by Jakub Libosvar
Modified: 2016-02-10 14:14 EST (History)
9 users (show)

See Also:
Fixed In Version: sf4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
server.log (9.97 KB, text/x-log)
2013-01-23 09:12 EST, Jakub Libosvar
no flags Details

  None (edit)
Description Jakub Libosvar 2013-01-23 09:12:29 EST
Created attachment 685931 [details]
server.log

Description of problem:
When accessing https://<rhevm-hostname>/api?rsdl NPE occurs:
HTTP Status 500 -
exception

org.jboss.resteasy.spi.UnhandledException: java.lang.NullPointerException
	org.jboss.resteasy.core.SynchronousDispatcher.handleApplicationException(SynchronousDispatcher.java:351)
	org.jboss.resteasy.core.SynchronousDispatcher.handleException(SynchronousDispatcher.java:220)
	org.jboss.resteasy.core.SynchronousDispatcher.handleInvokerException(SynchronousDispatcher.java:196)
	org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:551)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:513)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:125)
	org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
root cause

java.lang.NullPointerException
	org.ovirt.engine.api.restapi.resource.BackendApiResource.addSystemVersion(BackendApiResource.java:347)
	org.ovirt.engine.api.restapi.resource.BackendApiResource.get(BackendApiResource.java:305)
	sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	java.lang.reflect.Method.invoke(Method.java:601)
	org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:167)
	org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:257)
	org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:222)
	org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:211)
	org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:536)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:513)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:125)
	org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:847)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to https://<rhevm-hostname>/api?rsdl
2.
3.
  
Actual results:
NPE

Expected results:
rsdl

Additional info:
Full trace attached
Regression against 3.1
Comment 1 Jakub Libosvar 2013-01-23 09:13:12 EST
Oops, missed version. It's rhevm-3.2.0-4.el6ev.noarch
Comment 2 Michael Pasternak 2013-01-23 09:17:35 EST
i cannot reproduce this on my environment, sounds like deployment issue, can you see the backend version at /api <product_info>?
Comment 3 Jakub Libosvar 2013-01-23 09:23:54 EST
<product_info>
<name>oVirt Engine</name>
<vendor>ovirt.org</vendor>
<version major="3" minor="2" build="0" revision="0"/>
</product_info>
Comment 5 Michael Pasternak 2013-01-23 09:41:30 EST
ravi, please see if you can reproduce this BZ on mentioned build
Comment 6 Ravi Nori 2013-01-23 12:44:40 EST
Yes rhevm-3.2.0-4.el6ev.noarch throws an exception on /api?rsdl
Comment 7 Ravi Nori 2013-01-23 13:51:01 EST
The rsdl bug was fixed in rhevm-3.2.0-5.el6ev.noarch, I have verified that /api?rsdl work in rhevm-3.2.0-5.el6ev.noarch (sf4)
Comment 8 Michael Pasternak 2013-01-24 04:40:56 EST
(In reply to comment #7)
> The rsdl bug was fixed in rhevm-3.2.0-5.el6ev.noarch, I have verified that
> /api?rsdl work in rhevm-3.2.0-5.el6ev.noarch (sf4)

thanks Ravi, 

Jakub, please verify this bug against sf4.
Comment 9 Jakub Libosvar 2013-01-24 08:29:58 EST
Verified rhevm-restapi-3.2.0-5.el6ev.noarch
Comment 10 Itamar Heim 2013-06-11 04:51:21 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:51:25 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:51:32 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 04:55:46 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:25:53 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.