Bug 903258 - Need description of FALLOC_FL_PUNCH_HOLE flag for fallocate(2) system call
Need description of FALLOC_FL_PUNCH_HOLE flag for fallocate(2) system call
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.4
All Linux
low Severity low
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1011198
  Show dependency treegraph
 
Reported: 2013-01-23 10:28 EST by Eryu Guan
Modified: 2013-11-21 17:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: missing description of FALLOC_FL_PUNCH_HOLE flag on fallocate(2) man page Consequence: incomplete documentation Fix: document FALLOC_FL_PUNCH_HOLE flag on fallocate(2) man page Result: complete documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:55:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
man-pages-3.22-fallocate.patch (3.46 KB, patch)
2013-09-20 12:09 EDT, Peter Schiffer
no flags Details | Diff

  None (edit)
Description Eryu Guan 2013-01-23 10:28:46 EST
Description of problem:
punch hole support for ext4 has been added into rhel6.4 kernel via bug 739101, and it adds new flag FALLOC_FL_PUNCH_HOLE to fallocate(2)

Version-Release number of selected component (if applicable):
man-pages-3.22-20.el6
Comment 1 RHEL Product and Program Management 2013-01-27 01:47:09 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 Michael Kerrisk 2013-02-12 18:19:43 EST
This has already been documented in upstream since man-pages-3.36.
Comment 3 Peter Schiffer 2013-09-20 12:09:26 EDT
Created attachment 800562 [details]
man-pages-3.22-fallocate.patch
Comment 9 errata-xmlrpc 2013-11-21 17:55:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1695.html

Note You need to log in before you can comment on or make changes to this bug.