Bug 903281 - [abrt][a11y] libreoffice-core-3.6.3.2-8.fc18: SwAccessibleFrame::IsOpaque killed by signal 11 (SIGSEGV)
[abrt][a11y] libreoffice-core-3.6.3.2-8.fc18: SwAccessibleFrame::IsOpaque kil...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:365153dc86ed8968e65568f6f46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-23 11:07 EST by garethjdjones
Modified: 2013-12-04 08:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 08:16:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (32.96 KB, text/plain)
2013-01-23 11:07 EST, garethjdjones
no flags Details
File: build_ids (8.25 KB, text/plain)
2013-01-23 11:07 EST, garethjdjones
no flags Details
File: cgroup (129 bytes, text/plain)
2013-01-23 11:07 EST, garethjdjones
no flags Details
File: core_backtrace (9.79 KB, text/plain)
2013-01-23 11:07 EST, garethjdjones
no flags Details
File: dso_list (22.97 KB, text/plain)
2013-01-23 11:08 EST, garethjdjones
no flags Details
File: environ (1.63 KB, text/plain)
2013-01-23 11:08 EST, garethjdjones
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-23 11:08 EST, garethjdjones
no flags Details
File: maps (102.35 KB, text/plain)
2013-01-23 11:08 EST, garethjdjones
no flags Details
File: open_fds (657 bytes, text/plain)
2013-01-23 11:08 EST, garethjdjones
no flags Details
File: proc_pid_status (927 bytes, text/plain)
2013-01-23 11:08 EST, garethjdjones
no flags Details
File: var_log_messages (1.34 KB, text/plain)
2013-01-23 11:08 EST, garethjdjones
no flags Details

  None (edit)
Description garethjdjones 2013-01-23 11:07:44 EST
Description of problem:
While using libre office I created a table around some text. Seperate bullet points were put in to seperate rows, and when I tried to drag all the text in about 5 rows from one column to another the program closed itself.

Version-Release number of selected component:
libreoffice-core-3.6.3.2-8.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=6
crash_function: SwFrm::GetAttrSet() const
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.6.10-4.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 SwFrm::GetAttrSet() const at /usr/lib64/libreoffice/program/../program/libswlo.so
 #1 SwAccessibleFrame::IsOpaque(ViewShell*) const at /usr/lib64/libreoffice/program/../program/libswlo.so
 #2 SwAccessibleContext::InitStates() at /usr/lib64/libreoffice/program/../program/libswlo.so
 #3 SwAccessibleContext::SwAccessibleContext(SwAccessibleMap*, short, SwFrm const*) at /usr/lib64/libreoffice/program/../program/libswlo.so
 #4 SwAccessibleParagraph::SwAccessibleParagraph(SwAccessibleMap&, SwTxtFrm const&) at /usr/lib64/libreoffice/program/../program/libswlo.so
 #5 SwAccessibleMap::GetContext(SwFrm const*, unsigned char) at /usr/lib64/libreoffice/program/../program/libswlo.so
 #6 SwAccessibleMap::GetContextImpl(SwFrm const*, unsigned char) at /usr/lib64/libreoffice/program/../program/libswlo.so
 #7 SwAccessibleContext::getAccessibleChild(int) at /usr/lib64/libreoffice/program/../program/libswlo.so
 #8 AtkListener::updateChildList(com::sun::star::accessibility::XAccessibleContext*) at /usr/lib64/libreoffice/program/libvclplug_gtklo.so
 #9 AtkListener::handleChildRemoved(com::sun::star::uno::Reference<com::sun::star::accessibility::XAccessibleContext> const&, com::sun::star::uno::Reference<com::sun::star::accessibility::XAccessible> const&) at /usr/lib64/libreoffice/program/libvclplug_gtklo.so
Comment 1 garethjdjones 2013-01-23 11:07:49 EST
Created attachment 686063 [details]
File: backtrace
Comment 2 garethjdjones 2013-01-23 11:07:52 EST
Created attachment 686064 [details]
File: build_ids
Comment 3 garethjdjones 2013-01-23 11:07:54 EST
Created attachment 686065 [details]
File: cgroup
Comment 4 garethjdjones 2013-01-23 11:07:56 EST
Created attachment 686066 [details]
File: core_backtrace
Comment 5 garethjdjones 2013-01-23 11:08:01 EST
Created attachment 686067 [details]
File: dso_list
Comment 6 garethjdjones 2013-01-23 11:08:04 EST
Created attachment 686068 [details]
File: environ
Comment 7 garethjdjones 2013-01-23 11:08:06 EST
Created attachment 686069 [details]
File: limits
Comment 8 garethjdjones 2013-01-23 11:08:10 EST
Created attachment 686070 [details]
File: maps
Comment 9 garethjdjones 2013-01-23 11:08:14 EST
Created attachment 686071 [details]
File: open_fds
Comment 10 garethjdjones 2013-01-23 11:08:21 EST
Created attachment 686072 [details]
File: proc_pid_status
Comment 11 garethjdjones 2013-01-23 11:08:34 EST
Created attachment 686073 [details]
File: var_log_messages
Comment 12 David Tardon 2013-01-24 09:59:27 EST
I am getting a crash dragging a column of text to another column, but the top frames of the stack trace are different.

Steps to reproduce:
1. enable a11y (gsettings set org.gnome.desktop.interface toolkit-accessibility true)
2. open a new writer document
3. insert a table with at least 3 rows
4. insert some text into all rows in the first column
5. select the first column
6. drag it to the second column and drop it on the _second_ row
Comment 13 Caolan McNamara 2013-12-04 08:16:58 EST
Can't reproduce the exact problem, but fixed the one we can reproduce as http://cgit.freedesktop.org/libreoffice/core/commit/?id=f141505929c95c97ae4765d7c7221f07e41ef8e7

Proposed this for backporting upstream to 4.1

Note You need to log in before you can comment on or make changes to this bug.