Bug 90333 - Wrong version of java installed from Red Hat CD
Wrong version of java installed from Red Hat CD
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 22:14 EDT by Edward Tripp
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 19:08:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Tripp 2003-05-06 22:14:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
The Java version of the gcc package that I initially installed lacks the 
java.awt, javax.swing, etc. classes and components that I need for my Java 
programming. Also, the release included on the Red Hat CD is 1.3.1, which is 
not even close to the latest Java release from Sun.

I consider this a bug because after I installed the Java SDK 1.4.2 rpm from 
Sun and queried the system (java -version) the java -version is still 1.3.1, 
and I have to invoke my Java compiler with a full path name to get 1.4.2 
(/usr/java/j2sdk1.4.2/bin/java -version). I believe this is so because Sun's 
rpm put the new Java files in a different directory instead of updating the 
directory of Red Hat's original installation.

So, now I have two Javas running, and I don't know how to get rid of the old 
one! By the way, I have set the path to include the path for version 1.4.2, 
but I think version 1.3.1 has precedence. In order to work in Java, I have 
created an alias that uses the full path name to version 1.4.2.



Version-Release number of selected component (if applicable):
java 1.3.1

How reproducible:
Always

Steps to Reproduce:
1.java -version
2.
3.
    

Actual Results:  java version "1.3.1"

Expected Results:  java version "1.4.2 beta"

Additional info:
Comment 1 Richard Henderson 2004-10-03 19:08:06 EDT
Gcc's gcj compiler is completely unrelated to Sun's JDK.  The Java
version is 1.3 because that's what gcj implements.  And installing
a new JDK affects that not at all.

Note You need to log in before you can comment on or make changes to this bug.