Bug 903348 - [abrt] java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18: os::abort: Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18: os::abort: Process /usr/lib/jvm...
Status: CLOSED DUPLICATE of bug 957376
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:1535fa342fdb6fa0e5c2684287c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-23 14:29 EST by silicis
Modified: 2013-06-14 16:48 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 12:44:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (95.88 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: build_ids (4.00 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: cgroup (130 bytes, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: dso_list (10.93 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: environ (2.98 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: maps (57.91 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: open_fds (3.51 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: proc_pid_status (912 bytes, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: smolt_data (2.27 KB, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
File: var_log_messages (478 bytes, text/plain)
2013-01-23 14:29 EST, silicis
no flags Details
hs_err_pid log file (120.12 KB, text/x-log)
2013-01-25 02:02 EST, cralls
no flags Details
java fatal error log (84.50 KB, text/x-log)
2013-01-28 13:37 EST, silicis
no flags Details

  None (edit)
Description silicis 2013-01-23 14:29:20 EST
Version-Release number of selected component:
java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java -Xbootclasspath/a:/usr/share/icedtea-web/netx.jar:/usr/share/icedtea-web/plugin.jar:/usr/share/java/js.jar -classpath /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/lib/rt.jar sun.applet.PluginMain /tmp/icedteaplugin-jachen/27404-icedteanp-plugin-to-appletviewer /tmp/icedteaplugin-jachen/27404-icedteanp-appletviewer-to-plugin
core_backtrace: 603674cde330c29071d75821f9b0cde68823d548 0xb952 pthread_cond_timedwait@@GLIBC_2.3.2 /lib64/libpthread.so.0 c79574b25bf5a7e588023a630103dec729a6db25
crash_function: os::abort
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java
kernel:         3.7.2-204.fc18.x86_64
remote_result:  NOTFOUND
uid:            500

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 os::abort at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:1588
 #3 VMError::report_and_die at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/utilities/vmError.cpp:1018
 #4 JVM_handle_linux_signal at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp:528
 #6 PerfLongVariant::sample at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/perfData.cpp:219
 #7 sample_data at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/statSampler.cpp:154
 #8 collect_sample at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/statSampler.cpp:185
 #9 StatSamplerTask::task at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/statSampler.cpp:58
 #10 execute_if_pending at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/task.hpp:89
 #11 PeriodicTask::real_time_tick at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/task.cpp:78
 #12 WatcherThread::run at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/thread.cpp:1211

Potential duplicate: bug 853621
Comment 1 silicis 2013-01-23 14:29:22 EST
Created attachment 686189 [details]
File: backtrace
Comment 2 silicis 2013-01-23 14:29:24 EST
Created attachment 686190 [details]
File: build_ids
Comment 3 silicis 2013-01-23 14:29:25 EST
Created attachment 686191 [details]
File: cgroup
Comment 4 silicis 2013-01-23 14:29:27 EST
Created attachment 686192 [details]
File: dso_list
Comment 5 silicis 2013-01-23 14:29:28 EST
Created attachment 686193 [details]
File: environ
Comment 6 silicis 2013-01-23 14:29:31 EST
Created attachment 686194 [details]
File: limits
Comment 7 silicis 2013-01-23 14:29:33 EST
Created attachment 686195 [details]
File: maps
Comment 8 silicis 2013-01-23 14:29:35 EST
Created attachment 686196 [details]
File: open_fds
Comment 9 silicis 2013-01-23 14:29:36 EST
Created attachment 686197 [details]
File: proc_pid_status
Comment 10 silicis 2013-01-23 14:29:38 EST
Created attachment 686198 [details]
File: smolt_data
Comment 11 silicis 2013-01-23 14:29:39 EST
Created attachment 686199 [details]
File: var_log_messages
Comment 12 Deepak Bhole 2013-01-23 14:44:18 EST
Can you also attach /home/jachen/hs_err_pid31930.log please?
Comment 13 cralls 2013-01-25 01:58:16 EST
Installed Fedora 18
Installed the updates (~260)
Installed eclipse-phpeclipse package via "yum install eclipse-phpeclipse"
Added Eclipse as a favorite on the shortcut menu
Started Eclipse from shortcut
Selected default workspace location of /home/<user>/workspace and checked don't ask again
Clicked OK and program crashed


backtrace_rating: 3
Package: java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 14 cralls 2013-01-25 02:02:07 EST
Created attachment 687257 [details]
hs_err_pid log file
Comment 15 David Betz 2013-01-26 17:08:53 EST
I started eclipse for the 1st time, clicked a few times, and then it crashed. I don't remember what I clicked.

backtrace_rating: 3
Package: java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 16 silicis 2013-01-28 13:37:59 EST
Created attachment 689240 [details]
java fatal error log
Comment 17 Deepak Bhole 2013-01-28 14:04:11 EST
Per log in comment #13, the error looks like it is arising from Eclipse/SWT JNI code. Re-assigning.
Comment 18 Alexander Kurtakov 2013-05-08 12:44:57 EDT

*** This bug has been marked as a duplicate of bug 957376 ***

Note You need to log in before you can comment on or make changes to this bug.