This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 903385 - lorax issue creating the anaconda run-time image
lorax issue creating the anaconda run-time image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-23 16:15 EST by Stuart Blackburn
Modified: 2014-03-27 13:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: lorax-21.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-27 13:18:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stuart Blackburn 2013-01-23 16:15:58 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stuart Blackburn 2013-01-23 16:40:50 EST
Sorry, I apparently submitted the Bug report without providing this data.

Description of problem:
When using pylorax to create a custom FC18 ISO, the create_runtime method of RuntimeBuilder creates a 1GB ext4 partition by default. With increasing size of packages in the distro, we think this should be increased to 2GB. This seems to be the intention based on the comment on line 153 ("2GB sparse file compresses down to nothin"). 

Version-Release number of selected component (if applicable): 
lorax-18.29-1.fc18.x86_64

How reproducible:
Every time when we try to build a custom ISO from based on latest FC18 repos.

Steps to Reproduce:
I'm not sure how much detail you want on this. I could give you all our python scripts and config files, but I don't think you really want all of it. Bottom line, the pylorax class doesn't seem to provide a way to pass size value to treebuilder, and therefore we think the default needs to be increased, or it needs to become configurable.
1. Attempt to use the pylorax libraries to create an custom FC18 ISO via calls to treebuilder and repobuilder.

  
Actual results:
You get "No space left on device" errors and lorax fails to create an ISO.

Expected results:
Expected to get a valid ISO.

Additional info:
When we changed the code to make the default size=2 or size=0 (line 149), the ISO generates successfully.
Comment 2 Brian Lane 2013-01-23 17:32:43 EST
Pass the size, in GiB, to create_runtime like this:

create_runtime(joinpaths(work_dir, runtime), size=2)

Or size=None to let it try and figure out how much space is needed.
Comment 3 Stuart Blackburn 2013-01-24 10:52:29 EST
(In reply to comment #2)
> Pass the size, in GiB, to create_runtime like this:
> 
> create_runtime(joinpaths(work_dir, runtime), size=2)
> 
> Or size=None to let it try and figure out how much space is needed.

We're trying to use the top-level Lorax class as is and have succeeded until now. The issue is that the lorax.run() method allows us to prep everything we need except this size. As written, the size cannot be passed into lorax.run() by any means that we are aware of, and the subsequent call it makes to create_runtime does not pass a size. We prefer not to have to branch off the official code stream in order to have access to set this size parameter.
Comment 4 Brian Lane 2013-01-24 12:20:32 EST
Ah! Thanks for the clarification. That should be simple to add.
Comment 5 Fedora Admin XMLRPC Client 2013-02-04 10:05:15 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.