Bug 903441 - SELinux is preventing /usr/libexec/mysqld from 'write' accesses on the directory systemd-private-yILHYy.
SELinux is preventing /usr/libexec/mysqld from 'write' accesses on the direct...
Status: CLOSED DUPLICATE of bug 903438
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c01c187e9ad2c03ce48e96e1cee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-23 20:49 EST by tiamatman
Modified: 2013-01-28 11:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-28 11:43:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2013-01-23 20:49 EST, tiamatman
no flags Details
File: hashmarkername (14 bytes, text/plain)
2013-01-23 20:49 EST, tiamatman
no flags Details

  None (edit)
Description tiamatman 2013-01-23 20:49:09 EST
Additional info:
libreport version: 2.0.18
kernel:         3.6.11-5.fc17.x86_64

description:
:SELinux is preventing /usr/libexec/mysqld from 'write' accesses on the directory systemd-private-yILHYy.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If aby mysqld powinno mieć domyślnie write dostęp do systemd-private-yILHYy directory.
:Then proszę to zgłosić jako błąd.
:Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
:Do
:można tymczasowo zezwolić na ten dostęp wykonując polecenia:
:# grep mysqld /var/log/audit/audit.log | audit2allow -M mojapolityka
:# semodule -i mojapolityka.pp
:
:Additional Information:
:Source Context                system_u:system_r:mysqld_t:s0
:Target Context                system_u:object_r:httpd_sys_rw_content_t:s0
:Target Objects                systemd-private-yILHYy [ dir ]
:Source                        mysqld
:Source Path                   /usr/libexec/mysqld
:Port                          <Nieznane>
:Host                          (removed)
:Source RPM Packages           mysql-server-5.5.29-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-166.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.11-5.fc17.x86_64 #1 SMP Tue
:                              Jan 8 21:40:51 UTC 2013 x86_64 x86_64
:Alert Count                   4
:First Seen                    2002-01-04 03:11:01 CET
:Last Seen                     2002-01-04 03:53:06 CET
:Local ID                      558fe787-f791-4fb8-9336-99995aea3600
:
:Raw Audit Messages
:type=AVC msg=audit(1010112786.224:30): avc:  denied  { write } for  pid=1154 comm="mysqld" name="systemd-private-yILHYy" dev="sda1" ino=1704137 scontext=system_u:system_r:mysqld_t:s0 tcontext=system_u:object_r:httpd_sys_rw_content_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1010112786.224:30): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff15ac6460 a1=c2 a2=180 a3=8f0fe189 items=0 ppid=938 pid=1154 auid=4294967295 uid=27 gid=27 euid=27 suid=27 fsuid=27 egid=27 sgid=27 fsgid=27 tty=(none) ses=4294967295 comm=mysqld exe=/usr/libexec/mysqld subj=system_u:system_r:mysqld_t:s0 key=(null)
:
:Hash: mysqld,mysqld_t,httpd_sys_rw_content_t,dir,write
:
:audit2allow
:
:#============= mysqld_t ==============
:#!!!! The source type 'mysqld_t' can write to a 'dir' of the following types:
:# mysqld_db_t, tmp_t, mysqld_tmp_t, var_log_t, var_lib_t, var_run_t, mysqld_var_run_t, root_t
:
:allow mysqld_t httpd_sys_rw_content_t:dir write;
:
:audit2allow -R
:
:#============= mysqld_t ==============
:#!!!! The source type 'mysqld_t' can write to a 'dir' of the following types:
:# mysqld_db_t, tmp_t, mysqld_tmp_t, var_log_t, var_lib_t, var_run_t, mysqld_var_run_t, root_t
:
:allow mysqld_t httpd_sys_rw_content_t:dir write;
:
Comment 1 tiamatman 2013-01-23 20:49:12 EST
Created attachment 686414 [details]
File: type
Comment 2 tiamatman 2013-01-23 20:49:14 EST
Created attachment 686415 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2013-01-24 03:18:35 EST
Where is "systemd-private-yILHYy" located? Does it happen by default?
Comment 4 Daniel Walsh 2013-01-28 11:43:29 EST
These are all the same problem.  httpd_sys_content_rw_t has been misapplied.

*** This bug has been marked as a duplicate of bug 903438 ***

Note You need to log in before you can comment on or make changes to this bug.