Bug 90346 - Install fails on VIA CLE266 chipset system with LCD
Summary: Install fails on VIA CLE266 chipset system with LCD
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-07 12:24 UTC by Alan Cox
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-29 15:18:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2003-05-07 12:24:18 UTC
Its not clear if ultimately kernel or anaconda has to deal with this

[Pasted from discussion emails]
we have found one problem is when install RedHat9.0 and System BIOS be selected
to LCD as primary display device, LCD will display abnormal. We have found the
problem is caused by RedHat install Application to program VGA register directly
and not to use VESA interface.

This root cause is RedHat's programmer program VGA register directly (CRT is
working , but LCD timing register is different from CRT)

System "Display Device Select" of BIOS item set to LCD and LCD+CRT for RedHat
9.0 installation will cause system hang up in black and white dots screen

Our engineer has reproduced the problem on VIA's CLE demo board with the VT1631
LVDS daughter board connected to the LCD panel. The CRT and LCD screens both
went black or showed vertical white stripes abnormally right after running the
/sbin/loader. For RedHat 9.0, either graphical or text mode installation had the
same problem and couldn't proceed by then. But, if without using LVDS output, it
can work. For RedHat 8.0, everything is normal.


--- end

This appears to be because the device isnt 100% VGA compatible when using LCD
(the LCD timings apply I guess). I've asked for more info and to confirm "nofb"
boot option works around this. It seems we should avoid loading vgafb on this hw

Comment 1 Jeremy Katz 2003-05-16 22:05:46 UTC
Knowing if 'nofb' works would be helpful.

I guess we might have to have a blacklist of devices to do nofb on :(

Comment 2 Alan Cox 2003-05-16 22:38:37 UTC
Apparently so although I've had no 100% definitive confirmtion


Comment 3 Jeremy Katz 2003-07-29 00:10:37 UTC
Ever get a definitive confirmation?

If so, have something good for me to key off of to do 'nofb' by default on these?

Comment 4 Alan Cox 2003-07-29 11:32:42 UTC
I don't know of any way to verify if the CLE266 is driving an LCD panel without
getting quite deep and grungy. We can go that way if you want or we could
document it 8)

Comment 5 Jeremy Katz 2003-07-29 15:18:02 UTC
It's documented in multiple places now (syslinux screens, release notes, install
guide), so without a good way to detect a need to do it by default, that's going
to have to be enough I guess.


Note You need to log in before you can comment on or make changes to this bug.