Bug 903475 - hang KDE session with firewall-config
Summary: hang KDE session with firewall-config
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On: 915892
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-24 04:54 UTC by Ed Greshko
Modified: 2013-04-12 22:25 UTC (History)
6 users (show)

(edit)
Clone Of:
: 915892 (view as bug list)
(edit)
Last Closed: 2013-04-12 22:25:13 UTC


Attachments (Terms of Use)
strace of firewall-config (1.05 MB, text/plain)
2013-02-21 05:01 UTC, Ed Greshko
no flags Details

Description Ed Greshko 2013-01-24 04:54:03 UTC
Description of problem: I could only reproduce this in KDE.  GNOME and Xfce did not fail.
If the temporary authorization is allowed to expire, the system will become hung when an action is taken needing authorization.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start firewall-config as a normal user.
2. Enter the password as prompted.
3. Do *nothing* with firewall-config for about 4 minutes (I don't know the polkit timeout).
4. Toggle the "Current View" from Runtime to Persistent.
5. Your session is hung.
  
Actual results:


Expected results:


Additional info: The cursor moves but you can't enter the password and you can't raise any windows or access the menus. 

You can ssh into the system and kill the firewall-config process to regain your system.

Comment 1 Jiri Popelka 2013-02-15 13:43:12 UTC
Closing as I haven't been able to reproduce the problem with:

KDE 4.9.5
qt-4.8.4-11.fc18.x86_64
polkit-kde-0.99.0-5.fc18.x86_64
polkit-qt-0.103.0-4.fc18.x86_64
firewall-config-0.2.12-2.fc18.noarch

sorry Ed

Comment 2 Ed Greshko 2013-02-21 05:01:52 UTC
Created attachment 700356 [details]
strace of firewall-config

I can't get it *not* to fail on any of my systems....

Same components as you list.

Any chance there is something in the strace log?

Comment 3 Jiri Popelka 2013-02-21 09:06:29 UTC
(In reply to comment #2)
> Any chance there is something in the strace log?

I can't see anything.

I tried your steps once more, this time I even didn't leave the firewall-config window while waiting (for 10 minutes), but still no luck.

Comment 4 Martin Bříza 2013-02-21 11:40:21 UTC
It happens to me too. I left firewall-config opened for a while (about half an hour, didn't measure it) and after I raised the window again and chose to switch the view, I was asked for my password again. However, I couldn't enter it - keyboard input was entirely ignored. Mouse cursor could be moved but clicking didn't do anything. Switching to vt2 and killing firewall-config solved the problem.
So, please, can I ask you to reconsider closing this bug? I'll provide more information in case you want anything.
Thank you.

Packages:
polkit-kde-0.99.0-5.fc18.x86_64
polkit-qt-0.103.0-4.fc18.x86_64
qt-4.8.4-14.fc18.x86_64
kde-workspace-4.10.0-7.fc18.x86_64
firewall-config-0.2.12-2.fc18.noarch
I installed firewalld today - the system was upgraded F16->F17->F18.

Comment 5 Andrew Rossignol 2013-02-21 14:26:50 UTC
I was able to reproduce this bug on my system (Fedora 18, updated) following these steps. I had the exact same experience as Martin, but only waited 5 minutes or so.

Does it matter how firewall-config is started? I launched it from Konsole, if it makes a difference.

Comment 6 Thomas Woerner 2013-02-26 17:41:12 UTC
This is a GTK bug. The changed callback is signaled while the combobox popup is still there and has the focus. I have cloned the bug for gtk: #915892

This is not the case in Gnome, because it seems that it is not using lists in a ComboBox.

Pushed this interim solution into firewall-config: http://git.fedorahosted.org/cgit/firewalld.git/commit/?id=e2ae60bf86335ea914574174a722f0ffdfb81e2f

Comment 7 Fedora Update System 2013-04-03 10:45:25 UTC
firewalld-0.2.12-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firewalld-0.2.12-5.fc18

Comment 8 Fedora Update System 2013-04-04 23:58:49 UTC
Package firewalld-0.2.12-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.2.12-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4826/firewalld-0.2.12-5.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-04-12 22:25:15 UTC
firewalld-0.2.12-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.