This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 903504 - log level of creating networks/bridges events on host should be info
log level of creating networks/bridges events on host should be info
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity low
: beta
: 4.0
Assigned To: David Ripton
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 03:25 EST by Ofer Blaut
Modified: 2016-04-26 22:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 10:11:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1214036 None None None Never

  None (edit)
Description Ofer Blaut 2013-01-24 03:25:48 EST
Description of problem:

log level of creating networks/bridges events on host should be info 

currently events of creating vlans/bridges ... by nova-compute are in debug level

it should be changes into info level  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. change nova.conf to debug=true
2. create new network and launch VM ( to create the bridge )
3. check brctl / ip addr commands are viewed under /var/log/nova/compute.log 
with Info level 
  
Actual results:


Expected results:


Additional info:
Comment 2 David Ripton 2013-02-28 11:54:41 EST
This is a feature request, and we're in feature freeze upstream, and Perry said not to do this downstream-only and create divergence, so this needs to wait until upstream reopens for feature changes.  So 3.0.
Comment 3 David Ripton 2013-05-16 09:13:31 EDT
4.0 because Grizzly is feature-frozen.  I'll do this upstream for Havana.
Comment 4 David Ripton 2013-08-08 13:24:01 EDT
The oslo patch is https://review.openstack.org/#/c/40872/

Once that gets in, I can drop the nova patch that depends on it.

(I can't just change LOG.debug to LOG.info because the logging is actually inside a library that comes from oslo.)
Comment 5 David Ripton 2013-08-15 10:44:15 EDT
The oslo patch got in.  2548344ec64

I need to merge it into nova, and then I can do the actual logging level patch.
Comment 6 David Ripton 2013-08-19 13:15:27 EDT
The oslo patch was merged to nova in 599af3570a

The patch to use INFO rather than debug for brctl and significant 'ip addr' commands is https://review.openstack.org/#/c/42689/

I also created a launchpad bug for this, which is in the External Tracker field.
Comment 7 David Ripton 2013-08-29 10:10:56 EDT
This got a -1 upstream as creating too much noise in the logs.  Looks unlikely to get in, unless someone makes a strong evidence-based argument for it in Gerrit.
Comment 8 David Ripton 2013-09-04 10:11:02 EDT
This got a -2 upstream.  Not because of a problem with the code, but because two core reviewers think it's too much noise in the logs.  So you have to continue to set the loglevel to DEBUG manually in nova.conf.  Setting to WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.