This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 903528 - gnome-terminal spins on CPU
gnome-terminal spins on CPU
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 04:00 EST by Zdenek Kabelac
Modified: 2013-02-18 11:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 11:13:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb session when it's looping before gdb fails (5.24 KB, text/plain)
2013-01-24 04:00 EST, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2013-01-24 04:00:46 EST
Created attachment 686568 [details]
gdb session when it's looping before gdb fails

Description of problem:

Usually few times per day  gnome-terminal suddenly becomes unresponsive and eats 100% CPU and requires to be killed.

Unfortunately getting proper backtraces with gdb-7.5.50.20130118-2.fc19 is currently impossible, since it triggers and internal gdb error (bug 903522)

So - at least I'll attach short gdb session of tracing gnome-terminal when the loop is going on.

Unsure if it will make more obvious.
Also so far I've no idea what exactly triggers looping.


Version-Release number of selected component (if applicable):
gnome-terminal-3.7.1-1.fc19.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yanko Kaneti 2013-01-24 15:28:52 EST
This was fixed upstream a week ago.
e3e20b5..08b99e2
Comment 2 Yanko Kaneti 2013-02-18 11:13:00 EST
I'll close this one. 3.7.2 in rawhide should be fixed.

Note You need to log in before you can comment on or make changes to this bug.