Bug 903534 - Unable to diff files from UI , displays message "Differences exist in a file that is not readable by all. Re-deployment of configuration file is recommended."
Unable to diff files from UI , displays message "Differences exist in a file ...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.9
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On:
Blocks: 902787 space19
  Show dependency treegraph
 
Reported: 2013-01-24 04:09 EST by Neha
Modified: 2013-03-06 13:34 EST (History)
0 users

See Also:
Fixed In Version: rhncfg-5.10.40-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (926 bytes, patch)
2013-01-24 04:42 EST, Neha
no flags Details | Diff

  None (edit)
Description Neha 2013-01-24 04:09:36 EST
Description of problem:

Not able to compare files from Graphical interface. Always display message  "Differences exist in a file that is not readable by all. Re-deployment of configuration file is recommended."

Version-Release number of selected component (if applicable):
rhncfg*-5.10.27-11.el5sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install rhncfg*-5.10.27-11.el5sat.noarch packages on client system.
2. System should be subscribed to a config channel and config file.
3. On clinet machine permission should be root:root 664 /root/test
4. Now try to shedule comparison from GUI - systemprofile -> configuration -> compare files
5. Run rhn_check -vvv on client machine.


Actual results:

Always display messgae "Differences exist in a file that is not readable by all. Re-deployment of configuration file is recommended."

  
Expected results:

Should display result of comparison.

Additional info:
This is a regression bug, GUI functionality is working correctly using rhncfg*-5.10.27-8.el6sat.noarch packages.

After debugging further, we can see the code belongs to this issue in /usr/share/rhn/config_common/file_utils.py -


128                 else:
129                     raise e
130         else:
131             result = ''.join(diff(path, temp_file))
132 

On line 131 is the code which is used to call the diff function with a src and dst. Here path which is the actual file on the client system is sent as SOURCE and temp_file is being set as DESTINATION.

If I swap the values on line 131 making the call as 
result = ''.join(diff(temp_file, path))
then the result of compare events scheduled by WEB UI works perfectly fine.
Comment 1 Tomas Lestach 2013-01-24 04:24:45 EST
Resetting to 'Clients' component as the patch is for the rhncfg code.
Comment 2 Neha 2013-01-24 04:42:21 EST
Created attachment 686604 [details]
Proposed patch
Comment 3 Stephen Herr 2013-01-28 19:04:09 EST
Patch accepted, thanks!

Committing to Spacewalk master as: 2fc32eb0081d67a803731a301d960faa396ebd84
Comment 4 Stephen Herr 2013-03-01 12:07:31 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 5 Stephen Herr 2013-03-06 13:34:55 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.