Bug 903591 - RFE: Show which debuginfo RPMs are missing not which symbols are unresolved
RFE: Show which debuginfo RPMs are missing not which symbols are unresolved
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.3
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: abrt
BaseOS QE - Apps
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 06:13 EST by Alexander Todorov
Modified: 2013-08-08 05:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 05:25:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (124.59 KB, image/png)
2013-01-24 06:13 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2013-01-24 06:13:23 EST
Created attachment 686663 [details]
screen shot

Description of problem:

I had experienced Firefox crash and wanted to report it. 

Let alone the fact that ABRT requires me to run it as root in order to install packages it tells me it can't find 90 debug files. See screenshot. 

The issue is that ABRT gives me a list of the missing files but not the name of their packages or at least the name of the libraries/binaries. I have to manually search the provides for each debug file and install it by hand. 


Please improve this.
Comment 1 Denys Vlasenko 2013-02-27 08:02:18 EST
You can use "yum install FILE(s)" to make yum find and install packages which contain those FILEs. This trick works for debuginfos too.
Comment 2 Denys Vlasenko 2013-02-27 08:30:04 EST
Another problem is that we can't tell you the names of the packages because we don't know them. Otherwise (if we'd know the package names), we'd be able to install them, and there will be no "Missing debuginfo file" messages.
Comment 3 Alexander Todorov 2013-02-28 04:58:39 EST
(In reply to comment #2)
> Another problem is that we can't tell you the names of the packages because
> we don't know them. Otherwise (if we'd know the package names), we'd be able
> to install them, and there will be no "Missing debuginfo file" messages.

Can't you use "yum install FILE(s)" as you suggest then?
Comment 4 Jiri Moskovcak 2013-08-08 05:25:57 EDT
(In reply to Alexander Todorov from comment #3)
> (In reply to comment #2)
> > Another problem is that we can't tell you the names of the packages because
> > we don't know them. Otherwise (if we'd know the package names), we'd be able
> > to install them, and there will be no "Missing debuginfo file" messages.
> 
> Can't you use "yum install FILE(s)" as you suggest then?

The reason for missing debuginfo files is the failed yum install FILE(s) so no, we can't improve it. It usually means, that you have installed something which is not in enabled repositories or is not packaged at all. And that's the reason why ABRT can't find the debuginfo. Denys's suggestion is mainly for debugging the issue, because if you're able to find the package running that command, then it means there is a bug in abrt.

Note You need to log in before you can comment on or make changes to this bug.