Bug 903726 - webadmin: the priority radio boxes under the "high availability" menu disappears when the storage is unavailable.
webadmin: the priority radio boxes under the "high availability" menu disappe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.2
x86_64 Linux
unspecified Severity medium
: ---
: 3.2.0
Assigned To: ofri
Artyom
sla
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-24 11:50 EST by Dafna Ron
Modified: 2016-02-10 15:15 EST (History)
9 users (show)

See Also:
Fixed In Version: sf7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (34.97 KB, image/jpeg)
2013-01-24 11:50 EST, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11467 None None None Never

  None (edit)
Description Dafna Ron 2013-01-24 11:50:53 EST
Created attachment 686854 [details]
screen shot

Description of problem:

I put my hosts in maintenance -> new server -> high availability -> the priority radio buttons are missing. 
thi happens when there is no DC/Cluster when creating a new vm

Version-Release number of selected component (if applicable):

si26.1

How reproducible:

100%

Steps to Reproduce:
1. put your hosts in maintenance 
2. go to vm's tab -> create new server
3. go to high availability 
  
Actual results:

the radio buttons are missing

Expected results:

the radio buttons should still be there even when the storage is unavailable. 

Additional info: screen shot
Comment 2 ofri 2013-01-28 07:26:03 EST
Dafna, how is this even a legal flow?...

If all hosts are down, you can't create a new VM. the "new server" button should not even be enabled in this situation...
Comment 3 Dafna Ron 2013-01-28 07:59:40 EST
(In reply to comment #2)
> Dafna, how is this even a legal flow?...
> 
> If all hosts are down, you can't create a new VM. the "new server" button
> should not even be enabled in this situation...

we never grey out the new Desktop/Server buttons. 

you can have more than one DC in the setup. the vm will select the DC by alphabetical order so just because that particular DC has no hosts does not mean that we cannot create new vm objects.
Comment 4 ofri 2013-01-28 09:31:04 EST
Posted upstream: http://gerrit.ovirt.org/#/c/11467/
Comment 6 Artyom 2013-03-18 09:01:45 EDT
Completed steps that describe above, radio button still on place.
Comment 7 Itamar Heim 2013-06-11 04:41:17 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:41:17 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 04:41:20 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 04:48:43 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.