Bug 903775 - Update command is deprecated but nomenclature still being used
Update command is deprecated but nomenclature still being used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
18
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 15:09 EST by Gerald Cox
Modified: 2014-09-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: dnf-0.3.9-1.giteff4c49.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 02:09:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2013-01-24 15:09:00 EST
Description of problem:
When issuing "dnf upgrade" command the first response is:
"Setting up Update Process"...
If "update" is deprecated, why would we be using that term?  It's just reinforcing it's use and makes it harder for the user to get it out of their mind.

If the decision was made to one term versus the other, we should be consistent.
Now it's just confusing, counter-intuitive and doesn't reinforce desired command syntax.  We're telling people we don't want them to use "update" to do an "upgrade" - but instead when they enter "upgrade" we're telling them they are doing an "update".

Yes, in the grand scheme of problems it is a nit - but it should be extremely easy to correct.

Version-Release number of selected component (if applicable):
dnf-0.2.17-1.git6a055e6.fc18.noarch

How reproducible:
Issue "dnf upgrade" command from terminal

Steps to Reproduce:
1.  Open terminal or kconsole
2.  Issue "dnf upgrade" command

Actual results:
Command responds...
"Setting up Update Process"

Expected results:
"Setting up Upgrade Process"

Additional info:
Comment 1 Gerald Cox 2013-01-24 15:46:33 EST
This also applies throughout the transaction...
i.e. 
Running Transaction
    Updating     :   package_name

Updated:
    package_name

Should be:

Running Transaction
    Upgrading     :  package_name

Upgraded:
    package_name
Comment 2 Ales Kozumplik 2013-01-25 02:15:42 EST
I didn't occur to me before but you are right, all those will have to be changed.

Also, until now I was careful not to change too many text outputs since DNF doesn't have its own translation project yet so no translations would work.
Comment 3 Ales Kozumplik 2013-04-16 11:56:28 EDT
Fixed by 44c4a41, will be included in dnf-0.3.3.
Comment 4 Fedora Update System 2013-04-17 11:22:48 EDT
dnf-0.3.3-3.git91ba5e0.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.3-3.git91ba5e0.fc19
Comment 5 Fedora Update System 2013-04-18 13:29:06 EDT
Package dnf-0.3.3-3.git91ba5e0.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.3.3-3.git91ba5e0.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6012/dnf-0.3.3-3.git91ba5e0.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-07-08 04:15:09 EDT
dnf-0.3.9-1.giteff4c49.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.9-1.giteff4c49.fc19
Comment 7 Fedora Update System 2013-07-18 02:09:15 EDT
dnf-0.3.9-1.giteff4c49.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.