This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 903873 - Ports show as N/A in status
Ports show as N/A in status
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 18:59 EST by Joe Julian
Modified: 2014-12-14 14:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-14 14:40:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2013-01-24 18:59:11 EST
# gluster volume status vmimages
Status of volume: vmimages
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick ewcs2:/var/spool/glusterfs/a_vmimages		24117	Y	28979
Brick ewcs10:/data/glusterfs/vmimages/a			N/A	Y	22780
Brick ewcs7:/var/spool/glusterfs/a_vmimages		24057	Y	17695
Brick ewcs2:/var/spool/glusterfs/b_vmimages		24118	Y	28985
Brick ewcs10:/data/glusterfs/vmimages/b			N/A	Y	22786
Brick ewcs7:/var/spool/glusterfs/b_vmimages		24058	Y	17701
Brick ewcs2:/var/spool/glusterfs/c_vmimages		24119	Y	28990
Brick ewcs10:/data/glusterfs/vmimages/c			N/A	Y	22792
Brick ewcs7:/var/spool/glusterfs/c_vmimages		24059	Y	17707
Brick ewcs2:/data/glusterfs/vmimages/d/brick		24210	Y	28998
Brick ewcs10:/data/glusterfs/vmimages/d			N/A	Y	22798
Brick ewcs7:/var/spool/glusterfs/d_vmimages		24060	Y	17713
Self-heal Daemon on localhost				N/A	Y	2888
Self-heal Daemon on ewcs2				N/A	Y	25352
Self-heal Daemon on ewcs4				N/A	Y	9618
Self-heal Daemon on ewcs7				N/A	Y	8829
Self-heal Daemon on ewcs10				N/A	Y	2750

Clearly, this isn't true that ewcs10 ports are N/A. 

ewcs10# netstat -tlnp | grep 22780
tcp        0      0 0.0.0.0:24042               0.0.0.0:*                   LISTEN      22780/glusterfsd    

ewcs10# ps -wwP 22780 
  PID PSR TTY      STAT   TIME COMMAND
22780   6 ?        Ssl  1955:35 /usr/sbin/glusterfsd -s localhost --volfile-id vmimages.ewcs10.data-glusterfs-vmimages-a -p /var/lib/glusterd/vols/vmimages/run/ewcs10-data-glusterfs-vmimages-a.pid -S /tmp/4065b5b92cc3ae94cf26ba7634dc3d3d.socket --brick-name /data/glusterfs/vmimages/a -l /var/log/glusterfs/bricks/data-glusterfs-vmimages-a.log --xlator-option *-posix.glusterd-uuid=ceed91d5-e8d1-434d-9d47-63e914c93424 --brick-port 24042 --xlator-option vmimages-server.listen-port=24042

I can't find anything in the logs seems to be related.

I tried killing one of the processes that's listed as N/A and restarting glusterd. This cause it to return the port correctly, however if I tried the same operation with a different brick, the working brick would return to having an N/A port result.
Comment 1 Niels de Vos 2014-11-27 09:54:06 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.

Note You need to log in before you can comment on or make changes to this bug.