Bug 903916 - ahci don't support hotplug
ahci don't support hotplug
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 22:45 EST by Suqin Huang
Modified: 2013-03-15 06:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 06:45:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2013-01-24 22:45:57 EST
Description of problem:
"Bus 'ahci.0' does not support hotplugging" error while hotplug a disk to AHCI controller

Version-Release number of selected component (if applicable):
qemu-kvm-1.3.0-3.el7.x86_64
seabios-1.7.2-0.2.gita810e4e7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot guest (with ahci controller)
/usr/libexec/qemu-kvm -nodefaults \
-drive file='/home/images/RHEL-Server-6.4-64.qcow2',if=none,id=drive-ide0-0-0,media=disk,cache=none,format=qcow2,aio=native \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \
-device virtio-net-pci,netdev=idUMvixC,mac=9a:87:88:89:8a:8b,bus=pci.0,addr=0x3,id='idMztaHV' -netdev tap,id=idUMvixC,vhost=on,script=/home/autotest-devel/client/virt/scripts/qemu-ifup-switch -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu 'Opteron_G3' -vnc :0 -vga cirrus -rtc base=utc,clock=host,driftfix=slew  \
-boot order=cdn,once=c,menu=off   -no-kvm-pit-reinjection -enable-kvm -monitor stdio \
-device ahci,bus=pci.0,id=ahci

2. hotadd drive and device
(qemu) drive_add 0 file=/root/ide2.qcow2,cache=none,if=none,id=disk2,format=qcow2

(qemu) device_add ide-hd,bus=ahci.0,id=ahci-disk,drive=disk2

3.
  
Actual results:
Bus 'ahci.0' does not support hotplugging

Expected results:


Additional info:
Comment 2 Paolo Bonzini 2013-03-15 06:45:34 EDT
The IDE bus does not support hotplug indeed.  AHCI is just a particular implementation of IDE.

Closing, but since this is not mst's territory I'm also changing the assignee to simplify future discussion.

Note You need to log in before you can comment on or make changes to this bug.