Bug 90396 - Janitorial alert: bad pagesize assumptions in X server
Summary: Janitorial alert: bad pagesize assumptions in X server
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 84131 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-07 16:55 UTC by Mike A. Harris
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 15:39:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2003-05-07 16:55:42 UTC
xf86getpagesize() implemented in os-support/linux/libc_wrapper.c is not
used throughout the server currently for code affected by processor
pagesize.

Global variables "xf86pagesize" and "xf86pagemask" should be set at server
startup with a call to xf86getpagesize().  This is particularly important on
platforms like ia64 and alpha where pagesize is kernel compile time selectable.

Comment 1 Mike A. Harris 2003-05-13 09:22:19 UTC
*** Bug 84131 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.