Bug 904061 - missing logrotate script
missing logrotate script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mysql (Show other bugs)
6.4
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
:
Depends On: 904059
Blocks: 960054
  Show dependency treegraph
 
Reported: 2013-01-25 06:56 EST by Karel Volný
Modified: 2014-12-16 11:34 EST (History)
8 users (show)

See Also:
Fixed In Version: mysql-5.1.71-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Logrotate script was missing in mysql-server Consequence: Logs rotation had to be configured manually Fix: mysql-server provides logrotate script now Result: users can use logrotate to log their mysqld.log file after un-commenting lines in the logrotate script
Story Points: ---
Clone Of: 904059
Environment:
Last Closed: 2013-11-21 15:41:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-01-25 06:56:00 EST
+++ This bug was initially created as a clone of Bug #904059 +++

Description of problem:
Mysql packages do not provide logrotate configuration file.
Looking at bug #647223 comment #16 I understand that as it should be included after the problem with rotating logs gets fixed. The problem got fixed already but we still do not provide /etc/logrotate.d/mysqld

Version-Release number of selected component (if applicable):
mysql-5.0.95-5.el5_9

How reproducible:
always

Steps to Reproduce:
1. yum install mysql-server
2. uncomment the configuration in /etc/logrotate.d/mysqld
3. logrotate -f /etc/logrotate.d/mysqld

Actual results:
2. no file to edit
3. error: cannot stat /etc/logrotate.d/mysqld: No such file or directory

Expected results:
no error; once the server runs and writes logfile, logs get rotated after logrotate call

Additional info:
Comment 2 Tom Lane 2013-01-25 09:53:29 EST
It looks like we fixed this in Fedora and RHEL5, but the fix never made it into the RHEL6 branch ... which makes this a regression from RHEL5 to RHEL6.  Oops.
Comment 12 Honza Horak 2013-08-09 04:23:24 EDT
How to reproduce:
1) (uncomment related lines in /etc/logrotate.d/mysqld)
2) # logrotate /etc/logrotate.d/mysqld -f
3) # echo $?
4) # ls -l /var/log/mysqld.log*

Actual results:
error: cannot stat /etc/logrotate.d/mysqld: No such file or directory
1
-rw-r-----. 1 mysql mysql 25910 Aug  9 10:07 /var/log/mysqld.log

Expected results:
0
-rw-r-----. 1 mysql mysql    0 Aug  9 10:14 /var/log/mysqld.log
-rw-r-----. 1 mysql mysql 2546 Aug  9 10:14 /var/log/mysqld.log.1.gz
Comment 14 errata-xmlrpc 2013-11-21 15:41:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1647.html

Note You need to log in before you can comment on or make changes to this bug.