Bug 904082 - RFE: Add support for getting monitor coordinates from multiple screens
Summary: RFE: Add support for getting monitor coordinates from multiple screens
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Hans de Goede
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: FutureFeature, OtherQA
Depends On: 951596
Blocks: 835616
TreeView+ depends on / blocked
 
Reported: 2013-01-25 12:25 UTC by Patrick van der Bleek
Modified: 2018-12-03 18:12 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 06:24:52 UTC


Attachments (Terms of Use)
xorg.conf (2.86 KB, text/plain)
2013-04-11 10:52 UTC, Hans de Goede
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1560 normal SHIPPED_LIVE spice-vdagent bug fix and enhancement update 2013-11-20 21:40:19 UTC

Description Patrick van der Bleek 2013-01-25 12:25:03 UTC
Description of problem:
In the use case where neither Xrandr nor Xinerama is used, but multiple qxl-vga cards are used the agent does not know how to detect screen sizes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a VM with multiple qxl cards
2. Run X without Xinerama or Xrandr
3. Connect through spice
  
Actual results:
spice-vdagent will not be able to detect screen sizes which will result in a virtual tablet with incorrect sizing.

Expected results:


Additional info:

Comment 2 RHEL Product and Program Management 2013-01-29 06:49:04 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Hans de Goede 2013-04-11 10:39:01 UTC
Fixed upstream with this comit:
http://cgit.freedesktop.org/spice/linux/vd_agent/commit/?id=a322d13b7ee7ced191d50e44ad8a79bdd6839779

Comment 5 Hans de Goede 2013-04-11 10:52:50 UTC
Created attachment 734115 [details]
xorg.conf

Here is an example xorg.conf for testing this, this assumes a RHEL-6 vm with 3 qxl devices, note the pci addresses in the config file likely need to be updated for your specific vm setup.

Comment 11 Hans de Goede 2013-06-26 06:49:16 UTC
This is fixed in spice-vdagent-0.14.0-1.el6 moving to MODIFIED,

Comment 17 errata-xmlrpc 2013-11-21 06:24:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1560.html


Note You need to log in before you can comment on or make changes to this bug.