Bug 904084 - RFE: Make session support run time configurable
Summary: RFE: Make session support run time configurable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Hans de Goede
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 951596
Blocks: 835616
TreeView+ depends on / blocked
 
Reported: 2013-01-25 12:28 UTC by Patrick van der Bleek
Modified: 2018-12-03 18:12 UTC (History)
7 users (show)

Fixed In Version: spice-vdagent-0.14.0-1.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 06:25:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1560 0 normal SHIPPED_LIVE spice-vdagent bug fix and enhancement update 2013-11-20 21:40:19 UTC

Description Patrick van der Bleek 2013-01-25 12:28:34 UTC
Description of problem:
Currently spice-vdagent depends on ConsoleKit. This is a compile-time parameter.
ConsoleKit is not always available.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Ability to disable ConsoleKit dependency at run-time.

Additional info:

Comment 2 RHEL Program Management 2013-01-29 06:47:13 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Hans de Goede 2013-04-11 15:23:28 UTC
This is fixed by this commit:
http://cgit.freedesktop.org/spice/linux/vd_agent/commit/?id=a3dea8eb4b7175eb22e15f5696fbc186464a033b

Which adds a -X cmdline option for the system level spice-vdagentd, which disables its use of console-kit or systemd-logind.

Comment 11 Hans de Goede 2013-06-26 06:49:19 UTC
This is fixed in spice-vdagent-0.14.0-1.el6 moving to MODIFIED,

Comment 17 errata-xmlrpc 2013-11-21 06:25:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1560.html


Note You need to log in before you can comment on or make changes to this bug.