Bug 904090 - astromenace-data included gamedata, Its non-free.
Summary: astromenace-data included gamedata, Its non-free.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: astromenace-data (Show other bugs)
(Show other bugs)
Version: 18
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2013-01-25 12:33 UTC by mejiko
Modified: 2013-04-20 19:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 23:55:21 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mejiko 2013-01-25 12:33:49 UTC
Hello.

Astromenace-data is astromenace artwork package.
I viewed "License.txt", This "Artwork" is license GPL. (See License.txt)

Infomation:

Source RPM is "astromenace-data-1.2-6.fc18.src.rpm"
Artwork is "AstroMenaceSourceArt_070928.zip"


but Astromenace-data is included "Game-Data" (not "Artwork") files.

Files:

AstroMenaceSourceArt/Ready for use game data/*


This game-data license is not GPL.
I viewed this license, Its non-free. (because this license is not permit modify)
See bug URI and License URI.

License URI:

http://sourceforge.net/p/openastromenace/feature-requests/_discuss/thread/61f348b1/38df/attachment/License.txt

#bug URI

http://sourceforge.net/p/openastromenace/feature-requests/1/

#current Changelog URI

http://sourceforge.net/p/openastromenace/code/256/tree/ChangeLog.txt

Upstream version already fixed (Version 1.3.1).
And, This is content, not code.

Seggests:

1. Upgrade fixed version.
2. Fix license tag.
3. Remove non-free content and rebuild.
4. Replace Fedora free (Fedora acceptable licensed file) files.
5. Remove Fedora repos. 


Thanks.

Reference:

https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Content_Licenses
https://fedoraproject.org/wiki/Packaging:Guidelines#Code_Vs_Content

Comment 1 mejiko 2013-01-25 12:34:34 UTC
Blocking FE-Legal, This is license problem.

Comment 2 Gwyn Ciesla 2013-01-25 14:55:48 UTC
The latest upstream will not need the astromenace-data package, and the contencts are all GPLv3, CC-BY-SA, and Ubuntu Font License.  That last isn't on our license list.

http://font.ubuntu.com/ufl/ubuntu-font-licence-1.0.txt

Legal, can you have a look at this and see if it's OK?

Comment 3 Gwyn Ciesla 2013-02-15 14:58:37 UTC
Legal, Ping?

Comment 4 Tom "spot" Callaway 2013-02-21 22:20:08 UTC
Waiting on RH. Font licenses are fun. :/

Comment 5 Gwyn Ciesla 2013-02-22 13:32:48 UTC
That word.  I don't think it means what you think it means. ;)

Comment 6 mejiko 2013-03-07 11:35:37 UTC
(In reply to comment #4)
> Waiting on RH. Font licenses are fun. :/

Is this font license (ubuntu font license) is "Good License" ?

Thanks.

Comment 7 Tom "spot" Callaway 2013-04-02 17:30:56 UTC
The Ubuntu Font License 1.0 is non-free, specifically because it forbids "modifying a private copy". This means that you can only modify fonts under the UFL if you distribute them, and that is non-free.

While we feel that this is probably not the intent of the UFL, this is how it is worded. I'm not sure who to reach out to try to get the UFL fixed so that it is free (simply dropping those four words would do it).

Comment 8 Gwyn Ciesla 2013-04-03 16:46:18 UTC
What a ridiculous restriction.  It's unenforceable.  Oy.

Weeelllll, digging a bit more, I can't find a reference to that font anywhere else in the tarball.  I tried creating a modified tarball, pulling the ttf and the license file for the ttf, and rebuilding.  While building data. . .

DATA/SCRIPT/menu1.xml file added to VFS.
DATA/SKYBOX/1/skybox_front5.tga file added to VFS.
DATA/SKYBOX/1/skyboCan't find file ./RAW_VFS_DATA/FONT/Ubuntu-B.ttf !!!
VFS compilation process aborted!
x_left2.tga file added to VFS.

Peeking at the code, it seems to get the information about the fonts it needs in the code itself.  I can try patching it out, but I'll have to see if there's another font the game that has similar properties and call that instead.

What a mess.

Comment 9 Gwyn Ciesla 2013-04-03 17:19:09 UTC
I was able to patch the Ubuntu font out, it builds fine, and runs.  I looked all over for font weirdness and found none.  Any objection to my going forward with that?

Comment 10 Tom "spot" Callaway 2013-04-03 18:21:19 UTC
None from me, seems like the best approach at this time. I'm independently working to try to get the UFL fixed, but items under UFL 1.0 will have to choose to relicense to a newer release if that happens.

Comment 11 Gwyn Ciesla 2013-04-03 18:59:36 UTC
Ok, I'll get on that.

Comment 12 Fedora Update System 2013-04-03 20:07:38 UTC
astromenace-1.3.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/astromenace-1.3.1-1.fc18

Comment 13 Fedora Update System 2013-04-03 20:07:48 UTC
astromenace-1.3.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/astromenace-1.3.1-1.fc17

Comment 14 Fedora Update System 2013-04-03 20:07:58 UTC
astromenace-1.3.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/astromenace-1.3.1-1.fc19

Comment 15 Fedora Update System 2013-04-05 02:52:47 UTC
Package astromenace-1.3.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing astromenace-1.3.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4852/astromenace-1.3.1-1.fc19
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2013-04-15 23:55:24 UTC
astromenace-1.3.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2013-04-16 00:10:34 UTC
astromenace-1.3.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2013-04-20 19:17:04 UTC
astromenace-1.3.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.