Bug 9041 - ntpdate puts out invalid argument msg
ntpdate puts out invalid argument msg
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.2
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-01 09:07 EST by David Lawrence
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 11:27:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2000-02-01 09:07:21 EST
When using ntpdate to set the time/date on an Alpha, ntpdate gives the
message Can't adjust the time of day: Invalid argument when it finds a time
server.  JBJ intimates that this may be due to a missing patch in the
kernel.
Comment 1 Jeff Johnson 2000-02-01 13:19:59 EST
(Note: the patch I was remembering is the 500/HZ setting limit of 0 because
HZ is different on alpha).

The adjtime syscall is returning EINVAL. Off to glibc for further investigation
since
	nm ntpdate | grep adjtime
                 U adjtime@@GLIBC_2.1
Comment 2 Elliot Lee 2000-02-03 14:38:59 EST
It works for me on this Alpha here, with the xntp3 package from 6.1.

Note You need to log in before you can comment on or make changes to this bug.