Bug 90419 - failure to configure S3 ProSavageDDR KM266 video card.
failure to configure S3 ProSavageDDR KM266 video card.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-07 19:03 EDT by Ljubomir J. Buturovic
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-07 22:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ljubomir J. Buturovic 2003-05-07 19:03:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1) Gecko/20020827

Description of problem:
redhat-config-xfree86 chooses 'savage' driver for the above card. This driver
does not work for the card. A working driver is 'VESA driver (generic)'.
Xconfiguratior (in RedHat 8.0) used to set the driver correctly.

The workaround for the problem is to install the system, then manually change
the driver in /etc/X11/XF86Config configuration file to 'VESA driver (generic)'.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 9.0

    

Actual Results:  X windows doesn't work.

Expected Results:  X windows should work.

Additional info:
Comment 1 Mike A. Harris 2003-05-07 22:02:48 EDT
The savage driver supports this card.  If it doesn't work, then it needs to be
fixed.  I will not change this chip to use the vesa driver except as a last
ditch resort after receiving many bug reports from various users (this is the
first bug report), and after exhausting all options to try to fix the problem
occuring in the savage driver.

Please file a bug report against XFree86 indicating in as much detail as
possible what exactly is wrong.  "doesn't work" isn't enough detail to be
able to do anything.  State exactly what doesn't work, what you tried,
and then attach your config file and log file as bugzilla file attachments
to the report and I will try to troubleshoot with you to narrow the problem
down.

Closing request to change to "vesa" driver by default as WONTFIX.  We want
the drivers that don't work to get fixed.
Comment 2 Alexandre Strube 2003-06-25 22:12:06 EDT
There's a bug which is already open for this chip. What happens is that X won't
run at all in any resolution higher that 640x480. Changing the driver to the one
found at Tim Robert's page won't work at all.

As Buturovic said, the step to reproduce this bug is just try to install redhat
9. It won't work unless you change display's resolution to 640x480, and the
system get VERY unstable with some applications. I really would like to see a
correction for this, there's a new machine here which is stopped just because of
that.
Comment 3 Mike A. Harris 2003-06-27 22:51:03 EDT
In order for us to provide an update, would require someone outside of
Red Hat who has access to both the Savage hardware that is problematic,
as well as the specifications to that chip from VIA/S3, and a knowledge
of the chip's operation and of the XFree86 driver to investigate the
issue and hopefully fix it.  Once that occurs, and fixes are made available
from XFree86.org or from the Savage driver maintainer or VIA/S3, then I
can investigate incorporating them into future versions of Red Hat Linux,
and possibly even update the driver for future XFree86 security erratum for
Red Hat Linux 9.

Unfortunately, there is nothing that Red Hat can do directly about this
problem as we do not have any knowledge of how Savage video hardware works,
nor do we have the Savage video hardware specifications as VIA/S3 do not
make them publically available.  I also have no Savage hardware to work with
either, so all bugfixes we apply to the Savage driver come either directly
from the upstream maintainer, or come from XFree86 CVS.

As such, until it is fixed upstream, the official Red Hat workaround to this
problem is for users to reconfigure X to use the VESA driver.  This is not
the most optimal solution, but there is nothing else we can do.  Your best bet
is to file a bug report at http://bugs.xfree86.org and hope it gets fixed in
4.4.0.  If you do this, please paste the upstream bug report URL here in this
bug report, and it does get fixed upstream, feel free to indicate that here
as well in order for me to investigate the possiblity of updating the driver
to the new fixed version, or of backporting the specific fix.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.