This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 904251 - Automatic Volume Refresh
Automatic Volume Refresh
Status: CLOSED DUPLICATE of bug 821508
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 15:56 EST by Justin Brown
Modified: 2013-04-01 06:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-01 06:13:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of Proposed Button (39.95 KB, image/png)
2013-01-25 15:57 EST, Justin Brown
no flags Details

  None (edit)
Description Justin Brown 2013-01-25 15:56:41 EST
Description of problem:
I use virt-sparsify and virt-sysprep to deploy templates inside a filesystem directory storage pool.(Mostly because virt-manager cannot run sysprep.)

After the image is created from the CLI, I open virt-manager and start creating a VM for it. When I get to the point of attaching the disk, it's not in my storage pool. Furthermore, there's no refresh option when choosing a disk image. Instead, I have to go to Edit -> Connection Details -> Storage and refresh from there.

Version-Release number of selected component (if applicable):
This has been a problem in virt-manager for a long time, but I'm currently using 0.9.4.

How reproducible:
Always

Steps to Reproduce:
1. Create a new image in a storage pool.
2. Try to attach the image to a VM.
3. Image is not available until a manual refresh of the storage pool is performed.


Expected results:
Virt-manager should automatically refresh a storage pool whenever a user selects it. The other option would be to add a refresh button or a right click menu, so users don't have to open up "Connection Details."

Additional info:
A screenshot with proposed refresh button is attached.
Comment 1 Justin Brown 2013-01-25 15:57:11 EST
Created attachment 687676 [details]
Screenshot of Proposed Button
Comment 2 Cole Robinson 2013-04-01 06:13:28 EDT
Libvirt should do this for us automatically, there's already a bug tracking that.

*** This bug has been marked as a duplicate of bug 821508 ***

Note You need to log in before you can comment on or make changes to this bug.