Bug 90434 - gbk - switch laytout ruins modifier map
gbk - switch laytout ruins modifier map
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 03:56 EDT by darkeye
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 12:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darkeye 2003-05-08 03:56:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
When I use the gkb gnome keyboard layout switcher applet, it ruins the keyboard
modifier map. It makes several modifiers not work, including NumLock and Alt.

This is very annoying, as one is not able to use these modifiers as expected.
Having no NumLock means I'm unable to use the keypad anymore. Having Alt removed
means I can't use some hot key combinations involving Alt (e.g. switching
between workspaces)

Version-Release number of selected component (if applicable):
gnome-applets-2.2.0-8

How reproducible:
Always

Steps to Reproduce:
1. add gkb to your gnome panel
2. add the hungarian layout in addition to the default one
3. switch from the default to hungarian (and see modifiers ruined)
4. switch back to the default (and see modifiers still ruined)
    

Actual Results:  the modifier map is ruined after switching layouts

Expected Results:  while the keyboard layout should be changed, the modifier
table should remain intact.

Additional info:

In particular, I installed the gkb applet on my gome panel, and added a new
layout for Hungarian in addition to the default.

For the hotkey I chose the windows key + shift (Mod4-Shift_L)

The original modifier map, after logging in is the following:

xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):
 
shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Alt_R (0x71)
mod2        Num_Lock (0x4d)
mod3
mod4        Super_L (0x73),  Super_R (0x74)
mod5
 

the modifiers after switching to the hungarian layout is:

xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):
 
shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40)
mod2
mod3
mod4        Super_L (0x73),  Super_R (0x74)
mod5        Mode_switch (0x4e),  Mode_switch (0x71)


the modifiers after switching back to the default layout is:

xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):
 
shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40)
mod2
mod3
mod4        Super_L (0x73),  Super_R (0x74)
mod5        Scroll_Lock (0x4e),  Alt_R (0x71)


it's visible that switching to the hungarian layout ruins the modifier map
(removed Num_Lock altogether, moves Alt_R from mod1 to mod5, introduces these
Mode_switch things)

the command gkb uses to switch layouts are:

for the default:
xmodmap /home/darkeye/.gkb_default.xmm

for hungarian:
gkb_xmmap hu-101-lat2
Comment 1 Mark McLoughlin 2004-07-19 05:41:30 EDT
Is this a problem in Fedora Core 2? I think a lot of things have been
fixed here since then ...
Comment 2 darkeye 2004-07-19 05:54:17 EDT
since then (this bug is more than a year old) I've switched to Gentoo,
but the problem was still there when I left RedHat, and was still
there in Gentoo as well. I guess it's a problem with the gkb layout files.
Comment 3 Mark McLoughlin 2004-07-21 12:36:16 EDT
We used a XKB based layout switcher now (gswitchit) which has its own
set of problems.

Note You need to log in before you can comment on or make changes to this bug.