Bug 904353 - Provide swift man page for the command line interface.
Provide swift man page for the command line interface.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-swiftclient (Show other bugs)
2.1
Unspecified Unspecified
medium Severity low
: snapshot5
: 2.1
Assigned To: Pete Zaitcev
Martina Kollarova
: Triaged
Depends On:
Blocks: 903322
  Show dependency treegraph
 
Reported: 2013-01-26 08:22 EST by Stephen Gordon
Modified: 2016-04-26 18:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 903322
Environment:
Last Closed: 2013-04-04 13:59:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Candidate 1 in openstack-swift (1.51 KB, patch)
2013-02-26 13:10 EST, Pete Zaitcev
apevec: review+
Details | Diff
Candidate 2 in python-swiftclient (6.96 KB, patch)
2013-02-27 15:13 EST, Pete Zaitcev
apevec: review+
Details | Diff

  None (edit)
Comment 1 Pete Zaitcev 2013-02-26 12:27:05 EST
The manpage for swift(1) was left behind in the Swift tree upstream by accident when python-swiftclient was split off. As a result, this requires a careful handling least we end with 2 RPMs that conflict over the file.
Comment 2 Pete Zaitcev 2013-02-26 13:10:20 EST
Created attachment 703049 [details]
Candidate 1 in openstack-swift

Patch to openstack-swift to drop swift.1
Comment 3 Alan Pevec 2013-02-26 14:06:13 EST
Comment on attachment 703049 [details]
Candidate 1 in openstack-swift

For reference, swiftclient change to add swift(1) is https://review.openstack.org/#/c/23003/

Spec change here looks good, I'd just suggest more user-friendly changelog
e.g. - Move swift manpage to python-swiftclient
Comment 5 Pete Zaitcev 2013-02-27 12:07:36 EST
http://fedoraproject.org/wiki/Packaging:Conflicts

"Keep in mind that implicit conflicts are NEVER acceptable." - e.g. if a possiblity of conflict on a file level between openstack-swift and python-swiftclient exists, we must resolve it at file level even if it means adding "Conflicts". However, man pages conflict commonly and there's a special suggestion:

 Man Page Name Conflicts

  * Rename the man pages to slightly alter the suffix of the man page
    (e.g man1/check.1.gz and man1/check.1foo.gz)
  * Rename the man pages to include a prefix of the providing package
    (e.g. foo-check.1.gz and bar-check.1.gz)
Comment 6 Pete Zaitcev 2013-02-27 15:13:15 EST
Created attachment 703624 [details]
Candidate 2 in python-swiftclient

This should be better - does not use the "Conflicts:" anymore, installs swift.1x. I verified this RPM to work as expected and man page available.
Comment 8 Pete Zaitcev 2013-02-28 13:58:06 EST
Modified in python-swiftclient-1.2.0-5. This is non-conflicting, but we
also removed the man page from openstack-swift in 1.7.4-10. In hindsight,
since the new man page is non-conflicting, we did not really need to remove
it as well as add, but we didn't know how that would turn out, so...
Well, no harm done. Stephen, enjoy the fix.
Comment 11 errata-xmlrpc 2013-04-04 13:59:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0706.html

Note You need to log in before you can comment on or make changes to this bug.