Bug 90439 - coreutils source: needs newer texinfo
Summary: coreutils source: needs newer texinfo
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: coreutils (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-08 09:31 UTC by Moritz Barsnick
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version: 5.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-08 09:47:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Moritz Barsnick 2003-05-08 09:31:15 UTC
Description of problem:
When trying to rebuild coreutils-5 on RedHat 7.3, it aborts because the 
available texinfo(-4.3) can't handle the texinfo source from coreutils.

Version-Release number of selected component (if applicable):
coreutils >= 5.0.0

How reproducible:
always (haven't rechecked newest RedHat Rawhide sources though)

Steps to Reproduce:
1. rpmbuild --rebuild coreutils-5.x.y-z.src.rpm
2.
3.
    
Actual results:
make error on texinfo: unexpected syntax

Expected results:
build cleanly

Additional info:
I don't have the log handy right now.  ;-)  Just try it. Upgrading to texinfo-
4.3 helps. So I assume
BuildRequires: ... texinfo ...
should be updated to something like
BuildRequires: ... texinfo >= 4.3 ...
I don't know whether texinfo-4.2 does the trick, I only tried 4.3.

Comment 1 Moritz Barsnick 2003-05-08 09:44:39 UTC
Sorry, the available texinfo on RedHat 7.3 is of course version 4.1. Typo, sorry

Comment 2 Tim Waugh 2003-05-08 09:47:39 UTC
Fixed in CVS; will appear in next build.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.