Bug 90443 - Accentuation (deadkeys) do not work correctly with US internation keyboard
Accentuation (deadkeys) do not work correctly with US internation keyboard
Status: CLOSED DUPLICATE of bug 80244
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 08:45 EDT by Luis Fernando C. Talora
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Fernando C. Talora 2003-05-08 08:45:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.2.1) Gecko/20030225

Description of problem:
When I type ' + c, the result is an accute-accentuated c ("ć", which does
not exist in Portuguese), instead of a cedil-c ("�"). It does not happen on
Mozilla for example, but happens in Evolution and many other parts of GUI.
It seems not to be a problem with kbdconfig; it's more like a distro problem. I
used to have the same problem on RH 8.0, and solved it changing $LANG from
"pt_BR.UTF-8" to "pt_BR" on /etc/sysconfig/i18n. It does not work on RedHat 9,
though.
There are also several translation bug on both versions (wrong "Ecr�" instead of
"Monitor" or "V�deo"; wrong "Ficheiro" instead of "Arquivo" -   just to cite a
few). You should seriouslly think about having a Brazillian guy taking care of
translation into Brazillian Portuguese.

Version-Release number of selected component (if applicable):
Any running over RH 8 and 9

How reproducible:
Always

Steps to Reproduce:
1. On GUI, press ALT+F2 (Run Program) and the try pressing ' + C (you'll need to
enable deadkeys to see the problem; maybe, I'll need to be using Brazillian
Portuguese to be sure to reproduce the problem)
2. Open Evolution program using and simply try to send a message. When typing
it, press ' + c and the problem shows it self.

    

Actual Results:  The result is an accute-accentuated c ("ć", which does not
exist in Portuguese), instead of a cedil-c ("�").

Expected Results:  A "�" should appear.

Additional info:

Feel free to mail me if you need more information. (talora@talora.com.br)
Comment 1 Alexandre Oliva 2004-01-06 12:13:45 EST
The problem is two-fold.  Part of it is that gtk+ and XFree86 use
different key compose rules, so you may end up with inconsistencies
and, in this case, you do.  The other part is that XFree86 has compose
rules that are uniform for all languages, and since there are
languages that use the ć character, it wouldn't be reasonable to map
that to ç.  The XFree86 way to generate ç in UTF8 locales is MultiKey
comma c, where MultiKey is most often the right-alt key, and comma is
just the `,' key.

gtk+ follows essentially the same rules, but with one exception: in pt
locales, it maps 'c to ç instead of ć.

So, depending on the locale and the application you use, you get
different results.

I've got used to MultiKey comma c sequence as a consistent way to
generate ç.  I don't know of any plans to introduce pt-specific
compose rules in XFree86 to match those of gtk+ but, if you'd like to
pursue this route, you'll be better off contacting the upstream
maintainers of XFree86.
Comment 2 Brent Fox 2004-01-06 14:13:19 EST
Perhaps a duplicate of bug #80244?
Comment 3 Mike A. Harris 2004-01-13 17:20:10 EST

*** This bug has been marked as a duplicate of 80244 ***
Comment 4 Avi Alkalay 2004-01-14 15:11:05 EST
I reported this bug to XFree, and it looks like the solution is on 
XFree CVS.
The problem is not 'ç', but the right-Alt key.

I found a way to fix it in KDE: There is a dialog option in Keyboard 
settings on KDE Control Center, that let you configure the 
functionality of several keys. I then srt right-Alt as RightMeta.
Comment 5 Mike A. Harris 2004-01-15 05:13:06 EST
Once XFree86 4.4.0 is released, and integrated into the distribution,
this problem should be resolved then hopefully.  If someone feels
like whipping up a minimal patch which just fixes this one issue
in the meantime however, I'll have a look at it, and if it appears
to be low-impact and safe, I will consider adding it to our 4.3.0
builds also.

If someone does attach a patch, please reopen the report.
Comment 6 Red Hat Bugzilla 2006-02-21 13:52:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.