Bug 9047 - ETerm del, home & end broken.
Summary: ETerm del, home & end broken.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-01 16:50 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-02 21:31:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the described problems (3.36 KB, patch)
2000-02-01 16:50 UTC, Hans de Goede
no flags Details | Diff
New patch for Eterm 0.9 (6.70 KB, patch)
2000-02-01 19:21 UTC, Hans de Goede
no flags Details | Diff

Description Hans de Goede 2000-02-01 16:50:11 UTC
ETerm claims to be an xterm but sends different ESC-sequences as listed in
terminfo for xterm.

To fix this add the following lines to the MAIN file of each theme, except
for the tn3720 theme, since this emulates an other terminal:
# To fix backspace, del, home & end to match Terminfo Xterm definition
    keysym 0xff08 "^H"
    keysym 0xffff "^[[3\~"
    keysym 0xff50 "^[OH"
    keysym 0xff57 "^[OF"

I've also attached a patch which should be applied from the themes dir with
-p1 which fixes all themes.

Comment 1 Hans de Goede 2000-02-01 16:50:59 UTC
Created attachment 86 [details]
patch to fix the described problems

Comment 2 Tim Powers 2000-02-01 17:07:59 UTC
Can you take a look at the latest Eterm in rawhide? The one we shipped in the
beta is not the one we will ultimately ship. We are going to ship Eterm-0.9. I
will also feed this to the Eterm maintainer to hear his thoughts on this, and
whether or not he will incorporate it into an official release.

Tim

Comment 3 Hans de Goede 2000-02-01 19:21:59 UTC
Created attachment 87 [details]
New patch for Eterm 0.9

I've attached a new patch which fixes the described problems, and removes the
menu binding for F1 so that its just F1 again.

Comment 4 Tim Powers 2000-02-01 19:35:59 UTC
OK. I sent the last 0.9 patch to Michael Jennings <mej@valinux.com> since he is
the maintainer of the code for Eterm. I sent it to him instead of applying it
myself to make sure that I don't conflict his design goals.

Tim

Comment 5 Tim Powers 2000-02-02 21:31:59 UTC
Should be fixed. Sent you a src rpm with the changes, plus the fixes you mailed
me privately.

I am closing this bug.

Tim


Note You need to log in before you can comment on or make changes to this bug.